Extra POI Editor (EPE) Problems/Issues/Comments

 

Has anyone else noticed the change in the map for EPE?

Also Is anyone else getting a Script Error when trying to use the Street View (little man) and then cant leave that view unless you go to another record?

--
Bobkz - Garmin Nuvi 3597LMTHD/2455LMT/C530/C580- "Pain Is Fear Leaving The Body - Semper Fidelis"
1 2 3
<<Page 4>>

New Google Earth Pro

oldboy wrote:

And wouldn't you know it, yesterday my GE got updated to Pro, completely unattended! Why all of a sudden I don't know. I even went into "Programs and Features" to check the install date to be sure I was not imagining.

On July 10, Google released Google Earth Pro version 7.3.0.3832. It combines the features of the old Google Earth "Free" and Google Earth Pro.

The announcement said that users with the older "Free" version would automatically get updated to the "new" Google Earth in the weeks to come:
https://productforums.google.com/forum/#!topic/maps/opv-ok9poRI

--
DriveAssist 50 (stolen), Nüvi 2595LMT

Google Earth Extension Insufficient For Our Needs

One thing the announcement makes clear that wasn't apparent before is the browser extension is not intended as a replacement for the old Google Earth Free. That's Google Earth Pro's job.

Upthread I saw someone comment about the extension and how it seemed to be a regression. Now we know why. For the features we need, the browser plugin is not sufficient.

I'm glad to know I'm not missing out on anything, given that the extension currently isn't available for Vivaldi.

--
"Anyone who is capable of getting themselves made President should on no account be allowed to do the job." --Douglas Adams

EPE v6.02 beta test

Here's EPE v6.02 as a beta test. I'd like to know if it fixes the GE issue before I post this officially. I also added some Lon/Lat coordinates validation when importing from CSV/XLS. Should help people isolate the issue when the coordinates have invalid characters or invalid values > 180 or < -180.

http://turboccc.wikispaces.com/file/detail/Extra_POI_Editor+...

EPE V6.02 Beta Test Result

No joy. I get the "EPE cannot find the path to Google Earth" message testing with the "new" Google Earth Pro.

Looking back at my email, I see I dropped " Pro" from the end of the subkey.
Sorry about that Turbo! The correct key is:
   HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Google\Google Earth Pro

--
DriveAssist 50 (stolen), Nüvi 2595LMT

Same Here

WAASup wrote:

No joy. I get the "EPE cannot find the path to Google Earth" message testing with the "new" Google Earth Pro.

Looking back at my email, I see I dropped " Pro" from the end of the subkey.
Sorry about that Turbo! The correct key is:
   HKEY_LOCAL_MACHINESOFTWAREWOW6432NodeGoogleGoogle Earth Pro

Before, I had the Google Earth free version and the Google Earth Pro. When I updated Google Earth to the latest version 7.3.0.3832, it combined the two into one--Google Earth Pro.

Using EPE, when I click on Tools > Open in GoogleEarth(tm) and Open in MapSource, I get this "EPE cannot find the path to Google Earth" error message. Only Open in BaseCamp works.

All details are important ;-)

Here's a new version looking for GE Pro.

http://turboccc.wikispaces.com/file/view/Extra_POI_Editor+V6...

Google Earth

If I didn't deliberately update Google Earth Pro yesterday I may not have encountered this issue.

6.03 works properly when calling Google Earth.

--
"Anyone who is capable of getting themselves made President should on no account be allowed to do the job." --Douglas Adams

Still No Joy

turboccc wrote:

Here's a new version looking for GE Pro.

http://turboccc.wikispaces.com/file/view/Extra_POI_Editor+V6...

Turbo,

Using EPE 6.03, and on a PC that just got updated to GE Pro from simple GE, I get no response when trying to open in Google Earth. Note that previously I got an error message from EPE, now I get nothing at all.

The "InstallLocation" exists in the following Registry locations:
HKEY_CURRENT_USER/Software/Google/Google Earth Plus
(NOT Google Earth Pro)
and in
HKEY_LOCAL_MACHINE/SOFTWARE/Wow6432Node/Google/Google Earth Pro

Thanks

InstallLocation Should Exist in Only One Place

oldboy wrote:

Using EPE 6.03, and on a PC that just got updated to GE Pro from simple GE, I get no response when trying to open in Google Earth. Note that previously I got an error message from EPE, now I get nothing at all.

The "InstallLocation" exists in the following Registry locations:
HKEY_CURRENT_USER/Software/Google/Google Earth Plus
(NOT Google Earth Pro)
and in
HKEY_LOCAL_MACHINE/SOFTWARE/Wow6432Node/Google/Google Earth Pro

Hi Oldboy,

Your problem can be fixed if Turbo changes EPE to search for the InstallLocation key in HKEY_LOCAL_MACHINE before HKEY_CURRENT_USER, or if you delete it from HKEY_CURRENT_USER/Software/Google/Google Earth Plus (using extreme caution).

Here's the thing. There should only be one InstallLocation key. At some point in the past, installing a new version should have removed it from the Google Earth Plus registry entry. Perhaps the uninstall failed?

You're getting no response because the new Google Earth program lives in the Google Earth Pro folder in Program Files. The InstallLocation key in HKEY_CURRENT_USER will point to the Google Earth folder, where the old "free" Google Earth used to live (it was removed when the new Google Earth Pro was installed). When EPE tries to call it, nothing happens since it no longer exists there.

--
DriveAssist 50 (stolen), Nüvi 2595LMT

It worked for me, but I don't know why

I updated Google Earth Pro last night from 7.18 to 7.3. I upgraded EPE to 6.02 today and tried calling Google Earth with it. No dice. I then went and upgraded to EPE 6.03 and tried calling Google Earth again. This time it worked.

--
"Anyone who is capable of getting themselves made President should on no account be allowed to do the job." --Douglas Adams

Multiple Google earths = bloated registry and program files

WAASup wrote:

...Here's the thing. There should only be one InstallLocation key. At some point in the past, installing a new version should have removed it from the Google Earth Plus registry entry. Perhaps the uninstall failed?

You're getting no response because the new Google Earth program lives in the Google Earth Pro folder in Program Files. The InstallLocation key in HKEY_CURRENT_USER will point to the Google Earth folder, where the old "free" Google Earth used to live (it was removed when the new Google Earth Pro was installed). When EPE tries to call it, nothing happens since it no longer exists there.

WASSup hit the nail on the head. He is supplying the specifics that confirm my gut feeling that this is the result of too many versions of Google Earth that have created a bloated registry and program files.

Disclaimer : Thanks to Google for a great free program!

Turbo shouldn't have to chase every permutation of failed registry entries created by Google in order to get EPE to work.

For years I have been getting rid of registry bloat by making a clean install of Windows 95, 98, XP and 7. After hearing about Google Earth this might be a good time to do it again.

dobs108 smile

Change the Key Value - It Works!

WAASup wrote:
oldboy wrote:

Using EPE 6.03, and on a PC that just got updated to GE Pro from simple GE, I get no response when trying to open in Google Earth. Note that previously I got an error message from EPE, now I get nothing at all.

The "InstallLocation" exists in the following Registry locations:
HKEY_CURRENT_USER/Software/Google/Google Earth Plus
(NOT Google Earth Pro)
and in
HKEY_LOCAL_MACHINE/SOFTWARE/Wow6432Node/Google/Google Earth Pro

Hi Oldboy,

Your problem can be fixed if Turbo changes EPE to search for the InstallLocation key in HKEY_LOCAL_MACHINE before HKEY_CURRENT_USER, or if you delete it from HKEY_CURRENT_USER/Software/Google/Google Earth Plus (using extreme caution).

Here's the thing. There should only be one InstallLocation key. At some point in the past, installing a new version should have removed it from the Google Earth Plus registry entry. Perhaps the uninstall failed?

You're getting no response because the new Google Earth program lives in the Google Earth Pro folder in Program Files. The InstallLocation key in HKEY_CURRENT_USER will point to the Google Earth folder, where the old "free" Google Earth used to live (it was removed when the new Google Earth Pro was installed). When EPE tries to call it, nothing happens since it no longer exists there.

Hey WAASup

I manually changed following Registry key InstallLocation
HKEY_CURRENT_USER/Software/Google/Google Earth Plus
to show a program folder of "Google Earth Pro".

The key
HKEY_LOCAL_MACHINE/SOFTWARE/Wow6432Node/Google/Google Earth Pro
did, and still does have location=Google Earth Pro

GE Pro opens just fine now from EPE. Will carry over to the other 2 systems.

Thank-you, thank-you, thank-you.

Another thought

dobs108 wrote:

For years I have been getting rid of registry bloat by making a clean install of Windows 95, 98, XP and 7. After hearing about Google Earth this might be a good time to do it again.

dobs108 smile

An app such a CCleaner may also be of assistance here.

--
"Anyone who is capable of getting themselves made President should on no account be allowed to do the job." --Douglas Adams

You're welcome oldboy

Change comes in many ways smile

--
DriveAssist 50 (stolen), Nüvi 2595LMT

Now It Works

As I previously posted, I too had about the same problem as oldboy's. I updated my version of EPE from 6.01 to the latest 6.03 and it now opens in both Google Earth Pro and BaseCamp. I forgot to mention that I didn't have MapSource already so it was moot and academic from the start. Thanks Turbo and everyone here for the ideas and tips!

Makes sense WAASup!

WAASup wrote:

Hi Oldboy,

Your problem can be fixed if Turbo changes EPE to search for the InstallLocation key in HKEY_LOCAL_MACHINE before HKEY_CURRENT_USER, or if you delete it from HKEY_CURRENT_USER/Software/Google/Google Earth Plus (using extreme caution).

Here's the thing. There should only be one InstallLocation key. At some point in the past, installing a new version should have removed it from the Google Earth Plus registry entry. Perhaps the uninstall failed?

You're getting no response because the new Google Earth program lives in the Google Earth Pro folder in Program Files. The InstallLocation key in HKEY_CURRENT_USER will point to the Google Earth folder, where the old "free" Google Earth used to live (it was removed when the new Google Earth Pro was installed). When EPE tries to call it, nothing happens since it no longer exists there.

I was expecting something like this as well. I definitively should have searched for GE Pro first but felt it may cause regressions so I just added the GE Pro if the other 2 searches failed. Next update, I'll search for GE Pro first then the other 2. Better and safer I guess.

Thanks for doing the test oldboy of changing the key value. It confirms everything.

Turbo

I Fixed The Registry

turboccc wrote:
WAASup wrote:

Hi Oldboy,

Your problem can be fixed if Turbo changes EPE to search for the InstallLocation key in HKEY_LOCAL_MACHINE before HKEY_CURRENT_USER, or if you delete it from HKEY_CURRENT_USER/Software/Google/Google Earth Plus (using extreme caution).

Here's the thing. There should only be one InstallLocation key. At some point in the past, installing a new version should have removed it from the Google Earth Plus registry entry. Perhaps the uninstall failed?

You're getting no response because the new Google Earth program lives in the Google Earth Pro folder in Program Files. The InstallLocation key in HKEY_CURRENT_USER will point to the Google Earth folder, where the old "free" Google Earth used to live (it was removed when the new Google Earth Pro was installed). When EPE tries to call it, nothing happens since it no longer exists there.

I was expecting something like this as well. I definitively should have searched for GE Pro first but felt it may cause regressions so I just added the GE Pro if the other 2 searches failed. Next update, I'll search for GE Pro first then the other 2. Better and safer I guess.

Thanks for doing the test oldboy of changing the key value. It confirms everything.

Turbo

Hi Turbo

On my two PCs failing to find GE, I manually added the InstallLocation value to the Registry at
HKEY_CURRENT_USER/Software/Google/Google Earth Plus
and EPE finds GE just fine.
Note: Value now exists in at least 2 locations in the Registry, and does not cause a problem (for me).

Sometime when I am truly bored, I will uninstall all things Google, manually delete all Reg-Keys that have anything to do with Google, then reinstall GE and see what I get.

Thanks

Need testers

Hi guys,

I made a few changes to EPE regarding the search for GE and GE Pro. It is not a major improvement but worth testing. If EPE finds a valid GE key, it checks for the .exe presence in the InstalledLocation first. If not found, it tries another key. It also searches for GE Pro first, then GE Plus then GE.

Oldboy, this mean you should be able to revert to the original key for GE.

http://turboccc.wikispaces.com/file/view/Extra_POI_Editor+V6...

Let me know if this works for all of you and I'll release this version.

Extra POI Editor

Yes , i have issues

EPE 6.04

The new version 6.04 found Google Earth without any problems.

When EPE was started, Windows 10 issued an alert and blocked it with a message "Windows Defender SmartScreen prevented an unrecognized app from starting. Running this app might put your PC at risk". I chose the "Run anyway" option.

EDIT: I uninstalled/re-installed EPE, updated to 6.04 from the ZIP and didn't get the alert from Windows Defender

--
DriveAssist 50 (stolen), Nüvi 2595LMT

Windows Defender

WAASup wrote:

The new version 6.04 found Google Earth without any problems.

When EPE was started, Windows 10 issued an alert and blocked it with a message "Windows Defender SmartScreen prevented an unrecognized app from starting. Running this app might put your PC at risk". I chose the "Run anyway" option.

EDIT: I uninstalled/re-installed EPE, updated to 6.04 from the ZIP and didn't get the alert from Windows Defender

So weird. Not sure what Windows Defender is complaining about since I don't have Win 10. This appeared with EPE 6.01 although I simply changed an html statement which has no incidence on security. Let's ignore this for now.

Thanks for testing EPE v6.04 with GE. I'll post it now. Thanks.

Turbo

What is your issue, sajidh?

sajidh wrote:

Yes , i have issues

What is your issue, sajidh?

Tested and Works (for me)

turboccc wrote:

Hi guys,

I made a few changes to EPE regarding the search for GE and GE Pro. It is not a major improvement but worth testing. If EPE finds a valid GE key, it checks for the .exe presence in the InstalledLocation first. If not found, it tries another key. It also searches for GE Pro first, then GE Plus then GE.

Oldboy, this mean you should be able to revert to the original key for GE.

http://turboccc.wikispaces.com/file/view/Extra_POI_Editor+V6...

Let me know if this works for all of you and I'll release this version.

Turbo

Latest 6.04 used on one system with GE, and another with GE Pro. Worked just fine in both.
(Note that InstallLocation value exists still in two different registry keys. I can delete one or the other if you need additional testing.)

Nah! Should be fine.

oldboy wrote:

Turbo

Latest 6.04 used on one system with GE, and another with GE Pro. Worked just fine in both.
(Note that InstallLocation value exists still in two different registry keys. I can delete one or the other if you need additional testing.)

Oldboy,

Nah! Should be fine. Thanks for testing.

Turbo

Problems with 6.04 on Win10

Had to uninstall 5.99 and run the full install to get the update to work.

Opened a POI gpx file, selected any POI and Open in Google Earth does not zoom in to location, but just to a slightly closer view of 1/2 of the earth, like it didn't get all the call parameters.

Double click a POI, Maximize Map. Grabbed stick figure to go to street view and every street changes to blue. Better where only the road under the stick figure highlights in blue.

--
Zumo 550 & Zumo 665 My alarm clock is sunshine on chrome.

As far

dave817 wrote:

Grabbed stick figure to go to street view and every street changes to blue.

AFAIK, Google maps streetview always works like that, at least when I drag the stick man over a Google Map on my computers. I think it is to indicate which streets have "streetview" available.

--
Nuvi 350, 760, 1695LM, 3790LMT, 2460LMT, 3597LMTHD, DriveLuxe 50LMTHD, DriveSmart 61, Garmin Backup Camera 40 and TomTom XXL540s.

As It Has Always Been?

dave817 wrote:

Had to uninstall 5.99 and run the full install to get the update to work.

Opened a POI gpx file, selected any POI and Open in Google Earth does not zoom in to location, but just to a slightly closer view of 1/2 of the earth, like it didn't get all the call parameters.

Double click a POI, Maximize Map. Grabbed stick figure to go to street view and every street changes to blue. Better where only the road under the stick figure highlights in blue.

I opened a .gpx file in EPE, selected a POI to open in GE, and GE zooms to a height of about 125m, giving me a field of view of about 1000m. As always (for me).

As for StreetView, all streets being highlighted in blue has been the way for as long as I remember.

GE and GEPro working the same for both.

POI in GE - oldboy & dave

Looks like the POI location is not opening in GE, right? Could you test with EPE 6.03 and tell me if it is the same?

Thanks.

Turbo

Had the exact same thing happen to me

I uninstalled EPE v.5,99 first

Tried to install EPE 602, 603, 604
I get the message that MCOMCTL.OCX file is missing.

Apparently Windows 10 does not have that file anymore. Found a copy and downloaded it. Instructions say to install in C:Windowssys64
Found this file at.

Link: https://www.ocxme.com/files/mscomctl_ocx

Edit 11:09am: Tried to install EPE again, now tells me RICHTx.OCX file missing.

EDIT 11:24am: Did another search in Google and found the RICHTx.OCX file as well. Copied it to C:Windowssys64
Found this file at.

Link: http://www.k6jm.com/hs-setupocx.htm

This time EPE v.6.04 did install and no GOOGLE error message.
BTW: I had none of the registry problems as has been discussed earlier.
Is the SOX.EXE file still required?

--
Nuvi 350 long gone, Nuvi 855LMT, Nuvi 2797LMT, DriveSmart 50 LMT-HD, 3790LMT now my daughters. Using Windows 10. DashCam A108C with GPS.

A question for the gurus

Melaqueman wrote:

I uninstalled EPE v.5,99 first

Tried to install EPE 602, 603, 604
I get the message that MCOMCTL.OCX file is missing.

Apparently Windows 10 does not have that file anymore. Found a copy and downloaded it. Instructions say to install in C:Windowssys64
Found this file at.

Link: https://www.ocxme.com/files/mscomctl_ocx

Edit 11:09am: Tried to install EPE again, now tells me RICHTx.OCX file missing.

EDIT 11:24am: Did another search in Google and found the RICHTx.OCX file as well. Copied it to C:Windowssys64
Found this file at.

Link: http://www.k6jm.com/hs-setupocx.htm

This time EPE v.6.04 did install and no GOOGLE error message.
BTW: I had none of the registry problems as has been discussed earlier.
Is the SOX.EXE file still required?

Just curious. Could the missing .ocx files come from a past overly-aggressive use of Revo Uninstaller?

Extra POI editor

Found another curiosity with v.6.04.
It cannot be installed like other programs. You have to unzip the download and then copy the complete download to a location of your choice. Additionally you need to go into this location and select "Create a shortcut on the Desktop". Otherwise you have no access to EPE editor.

Having said that, is this download designed to be dropped into an existing EPE editor folder to replace for example v.5.99 ???

--
Nuvi 350 long gone, Nuvi 855LMT, Nuvi 2797LMT, DriveSmart 50 LMT-HD, 3790LMT now my daughters. Using Windows 10. DashCam A108C with GPS.

Verrry interesting

CraigW wrote:

Just curious. Could the missing .ocx files come from a past overly-aggressive use of Revo Uninstaller?

Funny you should mention the Revo Uninstaller. I used to have that product but recently uninstalled it and I've had no problem installing all these new EPE releases. I'm Win 10, too.

BTW, what's the URL for 6.04? I installed the .zip copy but I'd rather install it with an installer.

Phil

--
Phil in Mentor, Ohio -- Garmin Nuvi 1450

Here I am again

After reading CraigW's comment I opened my Recycle bin and yes, Revo did indeed remove both files.

So does that mean the EPE v.5.99 installed them? On the web the info is that the MCOMCTl.ocx file does not come with Windows 10 any longer. Maybe the same reason for the RICHTx32.ocx file ?

I also will need to reinstall the EPE help file from a backup copy of v.5.99

--
Nuvi 350 long gone, Nuvi 855LMT, Nuvi 2797LMT, DriveSmart 50 LMT-HD, 3790LMT now my daughters. Using Windows 10. DashCam A108C with GPS.

Right Here

plunder wrote:
CraigW wrote:

Just curious. Could the missing .ocx files come from a past overly-aggressive use of Revo Uninstaller?

Funny you should mention the Revo Uninstaller. I used to have that product but recently uninstalled it and I've had no problem installing all these new EPE releases. I'm Win 10, too.

BTW, what's the URL for 6.04? I installed the .zip copy but I'd rather install it with an installer.

Phil

Don't we all get it from here? I got it from here: https://turboccc.wikispaces.com/Extra_POI_Editor

EPE

If you followed the thread links were posted for update v.6.02, v.6.03 and v.6.04 in this thread.

--
Nuvi 350 long gone, Nuvi 855LMT, Nuvi 2797LMT, DriveSmart 50 LMT-HD, 3790LMT now my daughters. Using Windows 10. DashCam A108C with GPS.

Installer Available

plunder wrote:
CraigW wrote:

Just curious. Could the missing .ocx files come from a past overly-aggressive use of Revo Uninstaller?

Funny you should mention the Revo Uninstaller. I used to have that product but recently uninstalled it and I've had no problem installing all these new EPE releases. I'm Win 10, too.

BTW, what's the URL for 6.04? I installed the .zip copy but I'd rather install it with an installer.

Phil

While Turbo's testing was going on 6.01(?), 6.02, 6.03, 6.04 were Zip files, to be extracted and copied to existing 5.99.

6.04 is now available as .exe installer:
http://turboccc.wikispaces.com/Extra_POI_Editor#toc5

POIs Open for Me OK

turboccc wrote:

Looks like the POI location is not opening in GE, right? Could you test with EPE 6.03 and tell me if it is the same?

Thanks.

Turbo

Turbo

Both "ALL POIs" and a "Selected POI" are opening just fine for me in GE and GE Pro.

Note: All my systems are Windows-7, so I may not be the best test-bed for the latest problems.

But - on another good note, I have had an issue for months where I would get an error opening POIs if Google Earth was *already open*.
I'd have to remember to close it first, before asking EPE to open in GE.
That issue was not related to it being either GE or GE Pro - problem just arrived out of the blue some time ago on GE and I ignored/worked around.
Everything now "works as advertised" but I have no idea what fixed it. I did not do an uninstall/reinstall of EPE, but I did for GE, but previously that *did not* fix the issue.

Confusing, Huh? Anyway, I'm happy.
Thanks.

EPE Download

oldboy wrote:

While Turbo's testing was going on 6.01(?), 6.02, 6.03, 6.04 were Zip files, to be extracted and copied to existing 5.99.

6.04 is now available as .exe installer:
http://turboccc.wikispaces.com/Extra_POI_Editor#toc5

You got that right, oldboy!

For those missing the OCX files, use the installer.
For those having EPE installed already, just copy the new .exe over the old one or simply re-install using the installer. Your choice.

For download, the official link is always:
http://turboccc.wikispaces.com/Extra_POI_Editor#toc5

Turbo

Fully confused! ;-)

oldboy wrote:
turboccc wrote:

Looks like the POI location is not opening in GE, right? Could you test with EPE 6.03 and tell me if it is the same?

Thanks.

Turbo

Turbo

Both "ALL POIs" and a "Selected POI" are opening just fine for me in GE and GE Pro.

Note: All my systems are Windows-7, so I may not be the best test-bed for the latest problems.

But - on another good note, I have had an issue for months where I would get an error opening POIs if Google Earth was *already open*.
I'd have to remember to close it first, before asking EPE to open in GE.
That issue was not related to it being either GE or GE Pro - problem just arrived out of the blue some time ago on GE and I ignored/worked around.
Everything now "works as advertised" but I have no idea what fixed it. I did not do an uninstall/reinstall of EPE, but I did for GE, but previously that *did not* fix the issue.

Confusing, Huh? Anyway, I'm happy.
Thanks.

I'm fully confused but I spotted the "I'm happy" part so I'll discard all the other words. Haha!

Turbo

Works now

turboccc wrote:

Here's a new version looking for GE Pro.

http://turboccc.wikispaces.com/file/view/Extra_POI_Editor+V6...

This one does work properly upon pulling up a GPX or CSV in Extra POI Editor--clicking "Open in Google Earth" does properly call up Google Earth Pro (and even puts the POIs in the Temporary Items slot properly in GE Pro). Thanks!

Great!

Thanks for the feedback. I think we are good with GE now. smile

Finding Duplicates

I use the Finding Duplicates feature a lot in EPE. Has anyone found a way to capture the results to print or copy them somewhere?

--
"Advice to children crossing the street: Damn the lights. Watch the cars. The lights ain't never killed nobody." - Moms Mabley Garmin StreetPilot C330, Garmin NUVI 765T, Garmin DriveSmart 60LMT

Export find duplicates

alleghany wrote:

I use the Finding Duplicates feature a lot in EPE. Has anyone found a way to capture the results to print or copy them somewhere?

Hi Alleghany,

There is no way that I know and I designed it wink

I could put a button to copy it to clipboard or export it to csv. If there is an interest, I can look into it. It should not be too complicated.

Can you clarify why you want to export it?

Thanks,

Turbo

I Have a Large POI File

the Missouri Cemetery file, about 8,400 records. When I run EPE, I get probably about 200 or so duplicates. Looking at a printout or csv file of them, I could isolate them quicker. Great program, by the way. I am a retired Senior Software Engineer.

--
"Advice to children crossing the street: Damn the lights. Watch the cars. The lights ain't never killed nobody." - Moms Mabley Garmin StreetPilot C330, Garmin NUVI 765T, Garmin DriveSmart 60LMT

Duplicates

Hi Alleghany,

Thanks for the feedback and the good words. I agree that 200 duplicates is a lot to go through.

I have never tried to seriously go through a long list of duplicates. EPE still puts them in order of proximity so you can see easily those which are closer to each other. Also, you can double click a POI in the Duplicate list to open it and see the POI details and its location on the large map. I figured this was the best way to determine if they were duplicates.

I don't mind at all providing an export to CSV or printout but this will become even more difficult to determine which one is which and find the real from the duplicate(s). You must have an idea that I missed. I was planning to export/printout the list viewed in EPE. That does not provide much information to determine the duplicates (poi name, lon, lat, address, dist). Is this really what you need?

All the best,
Turbo

Maybe Cemeteries are Unique

in that oftentimes, there will be 2 or 3 cemeteries right together, separated only by a fence or road, or not even separated at all. If it is a common road, then duplicates would be legitimate. Other times, cemeteries that are close to each other often go by several different names. Then, you have the case where I have the wrong coordinates, and duplicates in that case are bad. So, I have to go through each one on an individual basis to determine which is the case. Hence, a list, where I could check off corrections as I go, would help. I hope this makes sense.

--
"Advice to children crossing the street: Damn the lights. Watch the cars. The lights ain't never killed nobody." - Moms Mabley Garmin StreetPilot C330, Garmin NUVI 765T, Garmin DriveSmart 60LMT

A Workaround

Alleghany, I would like to suggest a workaround to dealing with duplicates in your Missouri Cemetery file using EPE itself.

I know you would like for EPE to be able to export the duplicates (or put out a text file you could use to zero in on the dups yourself), but there is another feature of EPE that should help.

I cannot find a Missouri Cemetery file on POI Factory so I cannot use your file in an explanation of the workaround I am suggesting. So, I will use the Rest Areas file (you might bring it up in EPE and follow along).

Bringing up RestAreasCombined_USA.csv in EPE shows a first entry of
"AK,AK-1,EB,MATANUSKA GLACIER STATE REC PARK REST AREA,MM101". This is fortuitous because EPE can sort any file based on distances from any location in the file. Since there is only one Alaska entry, this means that distances will be surrogate for finding duplicates.

You have already tried
Edit -> Find Duplicates (Ctrl+D)
so let's start with something else.

Assuming the Alaska entry is highlighted, let's do a
Tools -> Sort by Location (Ctrl+L)
and let EPE sort the file based on distances from the MATANUSKA GLACIER STATE REC PARK REST AREA.

This reorganized file is something one can use a "Save As" in order to work on the file and determine if there are indeed duplicates.

Now, let's do Edit -> Find Duplicates to bring up the duplicates but let's also click on Distance Match and enter 0.01 in the "km" field and then click "Ok".

The first few entries in the duplicate pane are (where I am showing the POI # also

0086 ID,US-95,SB,MINERAL MOUNTAIN REST AREA, MM371
0087 ID,US-95,NB/SB,SHEEP CREEK REST AREA, MM189

0227 CA,I-5,SB,LT JOHN C HELMICK REST AREA, MM632
0228 CA,I-5,SB,CLO...CONSTR...TO LT JOHN C HELMICK REST AREA, MM633
0229 CA,I-5,NB,CLO...CONSTR...TO LT JOHN C HELMICK REST AREA, MM633
0230 CA,I-5,NB,LT JOHN C HELMICK REST AREA, MM632

If I were doing your task, what I would be doing now would be to use a portable freeware program called Faststone Capture (I use it all the time to capture online bill paying confirmations, etc.) Find it at
https://www.portablefreeware.com/index.php?id=775

Once loaded (actually I have Faststone Capture as part of my "start-ups" so that I can use it whenever I need it) one can press "PrintScr" to capture the full screen or "Shift PrintScr" to capture only the active window.

In the case at hand, I would have to click in the scroll bar on the right of the Duplicates pane several time to capture all of the dups, but I would have something I could print to guide me while looking at the "reorganized" file I had saved.

Would this work for you?

Duplicates

@allegany: yes, makes sense! Thanks. I will check it out.

@jgermann: you're on fire! True, EPE can sort on locations from the selected POI so they will be all ordered and then you can export. Makes a big file though but it allows you to export.

My Offbeat POI file

turboccc wrote:

@allegany: yes, makes sense! Thanks. I will check it out.

@jgermann: you're on fire! True, EPE can sort on locations from the selected POI so they will be all ordered and then you can export. Makes a big file though but it allows you to export.

I use this feature a lot and have found myself wishing a way to Export all the "Duplications" that EPE finds. Then I could use Excel to look them over better. I do currently export all the entries to Excel and then have to do different search types to make sure there are no Dups. I first look for Description, then look for Phone numbers, then maybe even look at addresses, etc... Some of theses are not dups to me since my type can have more than 1 object in the same location only feet apart from each (example are statues)

So doing a Export from the Duplication list might be helpful so that I don't have to look at all the entries, Only the ones that EPE are reporting as dups within my km range.

--
Bobkz - Garmin Nuvi 3597LMTHD/2455LMT/C530/C580- "Pain Is Fear Leaving The Body - Semper Fidelis"

More to Allegany

Many someone will jump in with a different way to do what I am about to suggest. I would use Notepad++ to compare two files.

I have already suggested saving the reordered file (distances from Alaska in the case of the Rest Areas file). Then after finding duplicates based on a distance of 0.01 KM from each other, I would do a "Check All" in the duplicates pane, then delete all the checked entries.

Once all duplicates were deleted, I would do a "Save As" of the remainder of the file.

Using Notepad++, I would compare the two file - recognizing that the "differences" would be all of the duplicates - one after the other. This would let me note those entries that I needed to delete, correct, or otherwise modify.

My Excel is 2003 so I do not have a version that may very well have a "compare" facility.

Somebody jump in with other ideas.

1 2 3
<<Page 4>>