Extra POI Editor (EPE) Problems/Issues/Comments

 

Has anyone else noticed the change in the map for EPE?

Also Is anyone else getting a Script Error when trying to use the Street View (little man) and then cant leave that view unless you go to another record?

--
Bobkz - Garmin Nuvi 3597LMTHD/2455LMT/C530/C580- "Pain Is Fear Leaving The Body - Semper Fidelis"
2 3 4
Page 1>>

sponsored links

re EPE

Yes I got the script error message. When I went into street view I found that when I maximized the map then minimized and it went back to sat view. I guess turbo will have to reconfig the inner workings.

--
All the worlds indeed a stage and we are merely players. Rush

epe adjustments

I have the previous version on my machine. This way if the update needs tuning I wait till it's good before I start using it.

Yes

bobkz wrote:

Has anyone else noticed the change in the map for EPE?

Also Is anyone else getting a Script Error when trying to use the Street View (little man) and then cant leave that view unless you go to another record?

I had noticed that this behavior started about 2 weeks ago. In the past Turbo has had to make adjustments to EPE to accommodate changes in the interface with Google Maps. Hopefully he will check in and have the time to patch this for us. I've found that if I close and then reopen the record, I can continue until I attempt to enter street view again.

--
"There's no substitute for local knowledge" nüvi 750, nüvi 3597

Got an email this morning

Got an email this morning that EPE has been updated. Haven't had the chance to check into it.

--
All the worlds indeed a stage and we are merely players. Rush

Version 5.97 is avaiable now

d-moo70 wrote:

Got an email this morning that EPE has been updated. Haven't had the chance to check into it.

EPE version 5.97 is now available

http://turboccc.wikispaces.com/Extra_POI_Editor

--
GM Built-in Navigation system - Samsung S6 Edge+ Smartphone with Garmin Viago, Google Maps & HERE Apps

scroll halfway down

rjrsw wrote:
d-moo70 wrote:

Got an email this morning that EPE has been updated. Haven't had the chance to check into it.

EPE version 5.97 is now available

http://turboccc.wikispaces.com/Extra_POI_Editor

The above link takes you to the correct page but the heading says 2015-02-22 Update: JavaScript error is FIXED! Use v5.96. if you scroll halfway down the page to the actual link for the download it is the correct new version of 5.97

--
. Nuvi 2689, Nuvi 2460, Zumo 550, Zumo 450, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N, Garmin, built into my Jeep. .

Recent changes

If you click on resent changes you will find V5.98 zip file uploaded. Click that link then click filename or preview to download.
v5.98 - Added ability to change the geocoding match level in Preferences. Default is street number (door level) but can be changed to street address (street level). Helps for some countries.
Note script error still comes up when going to street view.

--
All the worlds indeed a stage and we are merely players. Rush

Confirmed

d-moo70 wrote:

If you click on resent changes you will find V5.98 zip file uploaded. Click that link then click filename or preview to download.
v5.98 - Added ability to change the geocoding match level in Preferences. Default is street number (door level) but can be changed to street address (street level). Helps for some countries.
Note script error still comes up when going to street view.

I just downloaded the 5.98 version. No mention of the script error on changes and fixes.

Thank You

Thanks for the information. I'm running 5.98 now without any problems.

I used 5.97 until a couple

I used 5.97 until a couple of days ago, and installed 5.98 yesterday, for no other reason than it was available. Had not been having any issues.

I used 5.98 last night with no problems. Suddenly today, I am getting the script errors.

I uninstalled, and re-installed 5.97, but I get the same script errors.

It seems to be happening only with entries that do not have long/lat entries. EPE allows me to geocode fine, shows location on the map, but as soon as my mouse hits any part of the map to fine-tune, I get the error.

Been there for a while

oldboy wrote:

...
It seems to be happening only with entries that do not have long/lat entries. EPE allows me to geocode fine, shows location on the map, but as soon as my mouse hits any part of the map to fine-tune, I get the error.

I am still on 5.95 and it has the scripts error.

Script Errors on EPE

Worked a couple of days ago, but script errors today. I'm in the middle of planning a trip.

Same as jgermann. Works until I try to fine tune.

Can anyone suggest another POI Editor?

--
NUVI2555LMT, NUVI350

Just say no

GPSgeek wrote:

Worked a couple of days ago, but script errors today. I'm in the middle of planning a trip.

...

and let it run. Has not caused any other problems for me.

Forgot I Had Licensed Copy of GEEPEX Editor

I had paid for a copy of GeePex Editor many years ago and forgot about it. I have temporarily switched to GeePex.

Seems to work pretty well.

Good size map and satellite view.

--
NUVI2555LMT, NUVI350

still fails

jgermann wrote:
GPSgeek wrote:

Worked a couple of days ago, but script errors today. I'm in the middle of planning a trip.

...

and let it run. Has not caused any other problems for me.

I tried that already, and does not work for me - just repeated script errors no matter whether I say "yes" or "no".

Same For Me

oldboy wrote:
jgermann wrote:
GPSgeek wrote:

Worked a couple of days ago, but script errors today. I'm in the middle of planning a trip.

...

and let it run. Has not caused any other problems for me.

I tried that already, and does not work for me - just repeated script errors no matter whether I say "yes" or "no".

Same for me. have to do the old CTRL-ALT-DEL thing to get out.

--
NUVI2555LMT, NUVI350

All Of A Sudden

GPSgeek wrote:
oldboy wrote:
jgermann wrote:
GPSgeek wrote:

Worked a couple of days ago, but script errors today. I'm in the middle of planning a trip.

...

and let it run. Has not caused any other problems for me.

I tried that already, and does not work for me - just repeated script errors no matter whether I say "yes" or "no".

Same for me. have to do the old CTRL-ALT-DEL thing to get out.

Only get script errors when using street view before, now just opening or loading a file. What's going on again? Does it have to do with this again? https://developers.google.com/maps/documentation/javascript/...

I just loaded the Rest Stops

I just loaded the Rest Stops to EPE so I could build the alert into a GPX file. No script error but when I selected street view for one of the pois the error came up. I clicked yes to continue running script and got the street view.

--
Charlie. Nuvi 265 WT and Nuvi 2597 LMT. Android Garmin Viago and Here Maps.

Script Error

charlesd45 wrote:

I just loaded the Rest Stops to EPE so I could build the alert into a GPX file. No script error but when I selected street view for one of the pois the error came up. I clicked yes to continue running script and got the street view.

What I notice is that the script error usually comes up every time I move the mouse pointer over the map. Sometimes choosing yes and sometimes no the script error message goes away temporarily. Also, choosing either yes or no and selecting street view, it displays it. Other times, end task is the only way out. Unpredictable. Imagine working on a poi file with dozens or more than a hundred entries already inputted and bang comes up the script error! That's why it's best to always save the file after every entry you make or you'll regret it. Like before, I believe it has to do with Google Maps API version or something related to it. Paging Turboccc again?

no

not me

--
[URL=http://www.speedtest.net][IMG]http://www.speedtest.net/result/693683800.png[/IMG][/URL]

Seems to be intermittent for me

oldboy wrote:

... but as soon as my mouse hits any part of the map to fine-tune, I get the error.

I'm still on 5.97, was not aware of an update. I've seen something similar before and then the problem went away. I then noticed this variation of the problem yesterday where moving the pointer to the map window caused the error. As others have commented, replying Yes or No makes no difference as long as the pointer remains in that pane. I typically copy/paste the coordinates from Google Maps so I generally don't have to fine-tune, but moving the mouse out of the way invariably touches the map. While I believe this is another case of Google changing something that introduces this behavior, I am puzzled that my experience yesterday was intermittent. If it still persists today I might try to figure out if it only occurs if a particular field is empty or populated.

--
"There's no substitute for local knowledge" nüvi 750, nüvi 3597

5.97 is the most current as of 2/16/2016

I see there are some references to a 5.98 version but after looking at Turboccc site, the current one is 5.97 and it still is buggy for the Street view scripting error, like other say, just click on ok (or Yes) and continue on, it still works.

--
Bobkz - Garmin Nuvi 3597LMTHD/2455LMT/C530/C580- "Pain Is Fear Leaving The Body - Semper Fidelis"

Except that

bobkz wrote:

I see there are some references to a 5.98 version but after looking at Turboccc site, the current one is 5.97 and it still is buggy for the Street view scripting error, like other say, just click on ok (or Yes) and continue on, it still works.

As others say, No it doesn't. Some of us can click Yes or No, until the cows come home, and it doesn't work.

After a dozen or so clicks I have managed to work my way through one entry, and that was a rarity.

I've also noticed that some of the co-ordinates returned can be all over the map of N.America. I managed to get EPE to do a batch Geocode and thought I was OK. One entry will be pretty good, and another, even though same address structure will be a few hundred miles out.

If any of you have managed to gecode over the last couple of days, you may want to verify your entries.

I've looked at this some more

oldboy wrote:

... As others say, No it doesn't. Some of us can click Yes or No, until the cows come home, and it doesn't work.

What I have observed is that when the error pops up, if I move the pointer off of the map display, I can then answer Yes (maybe twice) and all is good until I move the pointer over the map again.

Edit: Well, I was wrong! It works sometimes. This goes back to my earlier post this morning that it seems to be intermittent.

It also seems that if I OK out of the record once I have a name and coordinates filled in, I can then reopen that record and have no problem with the error when I place the pointer over the map and can then use it to refine the coordinates. This is really weird. Either Turbo will stop by in time and and possibly fix it, or Google will issue another change and the problem will change or disappear again.

--
"There's no substitute for local knowledge" nüvi 750, nüvi 3597

Same Here

oldboy wrote:
bobkz wrote:

I see there are some references to a 5.98 version but after looking at Turboccc site, the current one is 5.97 and it still is buggy for the Street view scripting error, like other say, just click on ok (or Yes) and continue on, it still works.

As others say, No it doesn't. Some of us can click Yes or No, until the cows come home, and it doesn't work.

After a dozen or so clicks I have managed to work my way through one entry, and that was a rarity.

I've also noticed that some of the co-ordinates returned can be all over the map of N.America. I managed to get EPE to do a batch Geocode and thought I was OK. One entry will be pretty good, and another, even though same address structure will be a few hundred miles out.

If any of you have managed to gecode over the last couple of days, you may want to verify your entries.

As others and I have noted, it's intermittent at times, can't get out at times until you end task, all sorts of possibilities. Also, as oldboy mentioned, geocoding with EPE sometimes will not produce good results. I've seen my entries locations dozens if not hundreds of miles away even though the address is right or inputted right. I often have to check and double check, but occasionally misses it. Gotta be careful. I really think it has to do with the API version again like before. I hope Turboccc will have the time to see to it.

Here is a link to 5.98

bobkz wrote:

I see there are some references to a 5.98 version but after looking at Turboccc site, the current one is 5.97 and it still is buggy for the Street view scripting error, like other say, just click on ok (or Yes) and continue on, it still works.

http://turboccc.wikispaces.com/file/detail/Extra_POI_Editor+...

--
Nuvi2797LMT, Nuvi765T

Thank you!

condump wrote:
bobkz wrote:

I see there are some references to a 5.98 version but after looking at Turboccc site, the current one is 5.97 and it still is buggy for the Street view scripting error, like other say, just click on ok (or Yes) and continue on, it still works.

http://turboccc.wikispaces.com/file/detail/Extra_POI_Editor+...

For the Life of me, I could not find this file.. Thank you for clarifying it for us!

--
Bobkz - Garmin Nuvi 3597LMTHD/2455LMT/C530/C580- "Pain Is Fear Leaving The Body - Semper Fidelis"

No Problem

I keep a bookmark saved and just change the version number to get to his latest files as sometimes the published links dont point to the correct files and I have found this to be a useful workaround.

--
Nuvi2797LMT, Nuvi765T

EPE v5.98

v5.98 - Added ability to change the geocoding match level in Preferences. Default is street
number (door level) but can be changed to street address (street level). Helps for
some countries.

Not really what you are looking for. smile

Javascrip error in StreetView

Hello everyone!

Got an email about this script error. Seems to be new. Most probably something changed again in the google API. I hate when this happens.

Thought it would be easy and ran the script in my web browser. Absolutely no error. I should have known. lol! It's NEVER easy. Haha!

Ok. So now you know I'm on the case. Will report as soon as I have something.

Cheers!

Turbo

Thanks Turbo

Thanks Turbo

--
All the worlds indeed a stage and we are merely players. Rush

EPE v5.99 - Fixed the scrip error with Street View

I think I found the issue. There's something that changed in the google map API that seems to affect the web browser widget in EPE. Whoa! That was weird and deep.

Luckily it looks like it is working for me, but I am not sure if this could cause issues for others. Please test and let me know. I'll put it officially on my wiki afterward.

Here's a link to v5.99:

http://turboccc.wikispaces.com/file/view/Extra_POI_Editor+V5...

Turbo

Geocoding precision

nats50 wrote:

As others and I have noted, it's intermittent at times, can't get out at times until you end task, all sorts of possibilities. Also, as oldboy mentioned, geocoding with EPE sometimes will not produce good results. I've seen my entries locations dozens if not hundreds of miles away even though the address is right or inputted right. I often have to check and double check, but occasionally misses it. Gotta be careful. I really think it has to do with the API version again like before. I hope Turboccc will have the time to see to it.

Although I added a new configurable parameter to control the precision of the geocoder (v5.98), the default precision is still street number which is the highest precision. This should give precision to the door level.

If you get bad results, it is most probably due to the geocoder itself. In doubts, send me an example of a bad geocoding position and I will double check. There could be an error somewhere.

Why did I added a less precise geocoding option? I got a request from someone in Peru where the geocoder never returns the precision at the door level. So I was asked to provide a street level result which was better than nothing. Just don`t use that setting in the Preferences.

Thanks Turbo!

Worked perfectly through 40+ entries.

Much appreciated.

5.98 0r 5.99

turboccc wrote:

I think I found the issue. There's something that changed in the google map API that seems to affect the web browser widget in EPE. Whoa! That was weird and deep.

Luckily it looks like it is working for me, but I am not sure if this could cause issues for others. Please test and let me know. I'll put it officially on my wiki afterward.

Here's a link to v5.99:

http://turboccc.wikispaces.com/file/view/Extra_POI_Editor+V5...

Turbo

Used the link for v5.99 but installation shows V 5.98 installed.

--
Charlie. Nuvi 265 WT and Nuvi 2597 LMT. Android Garmin Viago and Here Maps.

Incorrect version number

Yes. My mistake. Compiler crashed and lost the version. It is still good but shows only a bad version. Will post the new one in a few minutes.

EPE v5.99 showing v5.99

Thank You Much!

You're an angel heaven sent! Thanks again.

Thanks Turbo-Works Great

Loaded this afternoon. Windows 7, no problem

--
NUVI2555LMT, NUVI350

Thanks Turbo

Win 10, no problems

--
All the worlds indeed a stage and we are merely players. Rush

Great

Glad to hear it guys.

5.99 OK

So far, no problem with the new 5.99. Thanks!

Thank You!

I second the note of appreciation for checking in with us and taking the time to patch EPE.

--
"There's no substitute for local knowledge" nüvi 750, nüvi 3597

Working fine

Mine seems to work fine

Great!

This is good news. I'll post officially the new version on my wiki.

Works fine for me also

jale wrote:

So far, no problem with the new 5.99. Thanks!

Fixed the problem and works fine on my windows 10 64bit desktop

--
GM Built-in Navigation system - Samsung S6 Edge+ Smartphone with Garmin Viago, Google Maps & HERE Apps

Security Warning for TurboCCC web site

When I go to the TurboCCC web site to download the editor I get a big warning (below) from my virus/security software. Anyone else see this? Maybe it is confused; seems like lots of folks here use it. But Careful is better than Foolhearty.
thanks,
-cj

Warning: Trouble ahead

Whoa!
Are you sure you want to go there?

http://turboccc.wikispaces.com/Extra_POI_Editor may be risky to visit.

Why are you seeing this?
When we visited this site, we found it exhibited one or more risky behaviors.

You need to get a better

You need to get a better anti virus program. POI folks have been going there for years, with no problems at all.

--
Frank Nuvi 3597LMT 37.322760, -79.511267

(... it must have been looking at something)

phranc wrote:

You need to get a better anti virus program. POI folks have been going there for years, with no problems at all.

Well, it is McAfee, whis has some rep at least. But I certainly thought it strange, since no one here has ever mentioned it.
thanks.

Oh, it's been mentioned. As

Oh, it's been mentioned. As a matter of fact, every time a new version is released, someone always pops up and whines about their AV complaining about the site. But for heavens sake, just how long would the recommendations for EPE last if the site really was a malicious site? Obviously, you trust this site for files, how long do you think POI Factory would last if it routinely endorses malicious sites?

--
Frank Nuvi 3597LMT 37.322760, -79.511267
2 3 4
Page 1>>