Garmin 765T - Problems entering text (gets stuck/freezes momentarily)

 

I have a 765T (this is actually a replacement 7655T that Garmin sent me when I sent my other unit back in for repair due to a problem with the screen - pressing the screen and something else on the screen being selected.)

This replacement unit didn't seem to suffer from the same problem so I figured I was fine. However, I've been noticing that this replacemtnt unit tends to hesitate/freeze when entering text sometimes. I notice it mostly on the Where to go> Points of Interest area. If I select "Spell Name" or "Spell" after selecting any other options in this area, when the keyboard comes up and I start typing, when I get to the 2nd letter, the screen freezes for about 3-4 seconds. It looks like the unit registers the letters if I keep typing and they just all show up at once after the screen unfreezes. The unit doesn't behave like that in any other areas where you have to use the keyboard but only inside "Points Of Interest" areas. This is very annoying and I am pretty sure my original unit didn't behave this way. Anyone know how to fix this?

--
Garmin c340, Nuvi 350, Nuvi 765T, Nuvi 2360LMT
1 2 3 4
<<Page 5

4.0 seems much better than

4.0 seems much better than 3.90. I kinda like the red speed indicater, reminds me of my business checking account smile

--
Garmin Nuvi 765T, Garmin Drive 60LM

Definitely

Jery wrote:

4.0 seems much better than 3.90. I kinda like the red speed indicater, reminds me of my business checking account smile

Yes 4.0 is definitely better than 3.90 which came with my device. It took some getting used to the screen after the fix. Having become used to using an iPod Touch screen, I thought my screen was broken but between chatting with Garmin and testing out with a Palm Treo stylus and the tip of my finger I realized that the screen was working and that my perception had changed. Overall I am pleased with how it works now. There is still the GLG bug but I can live with that. Having stable traffic and a responsive screen outweighs anything else.

--
I support the right to keep and arm bears.

Happy Camper

I'm very happy with this update. I hate to admit that I was a skeptic, I really thought that Garmin would never address the problems with the 765. I figured that they had already moved on to bigger & better things & that they weren't really broken up if many of the 765 owners decided to upgrade rather than complain.

I happily & humbly apologize to our friends at Garmin! I've always liked their customer service, physical & interface design solutions & now the functionality is on par as well. My 765 seems like a new unit, one that no longer continually frustrates me! I even waited to post this until I had some time using the update as I was afraid that I had again gotten my hopes up too high, however, I'm happy to say that 4.0 has resolved all of my issues with my 765. Well, I haven't tried the bluetooth since but my main reason for the device is guidance & I'll settle for that.

I post my experience because I've been critical of Garmin when things weren't going so well, as have many others, & wanted to make sure that I didn't forget to post when I was happy with my Garmin. A common problem with regards to customer service is that you always hear from those who are unhappy but rarely from those who are. I have always used this site to see what real-life experiences people have with these devices & want to also give back to others contemplating a purchase.

Thanks again Garmin.

--
Not lost anymore. Well, not as it pertains to driving anyway. -Garmin Nuvi 765t, 56 unt Mac user.

Garmin 855 - Problems entering text (gets stuck/freezes moment

Poifect wrote:

I'm very happy with this update. I hate to admit that I was a skeptic, I really thought that Garmin would never address the problems with the 765. I figured that they had already moved on to bigger & better things & that they weren't really broken up if many of the 765 owners decided to upgrade rather than complain.

I happily & humbly apologize to our friends at Garmin! I've always liked their customer service, physical & interface design solutions & now the functionality is on par as well. My 765 seems like a new unit, one that no longer continually frustrates me! I even waited to post this until I had some time using the update as I was afraid that I had again gotten my hopes up too high, however, I'm happy to say that 4.0 has resolved all of my issues with my 765. Well, I haven't tried the bluetooth since but my main reason for the device is guidance & I'll settle for that.

I post my experience because I've been critical of Garmin when things weren't going so well, as have many others, & wanted to make sure that I didn't forget to post when I was happy with my Garmin. A common problem with regards to customer service is that you always hear from those who are unhappy but rarely from those who are. I have always used this site to see what real-life experiences people have with these devices & want to also give back to others contemplating a purchase.

Thanks again Garmin.

I am having the same problem with my GPS 855. Any body else has an 855 doing this.

--
3790LMT; 2595LMT; 3590LMT, 60LMTHD

Garmin's support not that good...

My experience with Garmin's support (via e-mail) is not that favourable.
Software update v4.0 corrected annoying typing issue and added some pizzas but screwed up other things; Oxford Language Guide retail or demo version on your nuvi does not pronounce words/sentences anymore.
And what Garmin tells me to do: reload application, reload nuvi software using WebUpdater. Support is basically dumb monkeys who read from preprinted paper or have predefined response depending on key words.

855 typing lag

rthibodaux wrote:

I am having the same problem with my GPS 855. Any body else has an 855 doing this.

There are times when the 855 processor gets bogged down and creates a slight typing lag. This is especially true right after boot up. But this is different than the typing lag on POI's on the 7x5 3.90 version. I don't think the two are related.

--
Alan - Android Auto, DriveLuxe 51LMT-S, DriveLuxe 50LMTHD, Nuvi 3597LMTHD, Oregon 550T, Nuvi 855, Nuvi 755T, Lowrance Endura Sierra, Bosch Nyon

Existing Bug

I have noticed an existing bug that was in 3.90 and is still in 4.00. I only figured out the way to reproduce it recently and I have to report it when I finally get a chance to sit down and write something coherent to Garmin support. In a nutshell, if you have a favorite that you want to navigate to and a picture is associated with it, clicking the "Go" button will not "Go" if the picture is not yet loaded in the display. About a month after I got the 765T, I would notice that I was starting off on my drive after having pressed "Go" and it was not routing. It was still in free drive mode. I would go back two or three times trying to get it to start routing and it wouldn't. Then the other day, under 4.00, I had the same thing happen again but I happened to recall that the picture was not yet displayed. I tried routing again before the picture appeared and, sure enough, it wouldn't go. Then I went back to the favorites, let the picture completely load, pressed "Go" and it worked. I had always thought it was something with 3.90 and the key press issues but that is not the case. It is a minor annoyance but hopefully I can get it into the system for the 4.10 update whenever that comes out.

--
I support the right to keep and arm bears.

855 typing lag

alandb wrote:
rthibodaux wrote:

I am having the same problem with my GPS 855. Any body else has an 855 doing this.

There are times when the 855 processor gets bogged down and creates a slight typing lag. This is especially true right after boot up. But this is different than the typing lag on POI's on the 7x5 3.90 version. I don't think the two are related.

This typing lag is in the Point of Interest. No other places. And that what was happenning with the 765. So they are related even tho the software is different. I have SW 4.70 in my GPS. It doesn't do it after a boot up.

--
3790LMT; 2595LMT; 3590LMT, 60LMTHD

Hmmm ....

I have both a 755T and 855. My 855 does not have the typing lag on POI spell ... never did that I recall. I just tested again to make sure. I am also on 4.70. I wonder if the 8x5 have different hardware versions like the 7x5. I dont see the hardware version on the diagnostic screen like I do on my 755T.

--
Alan - Android Auto, DriveLuxe 51LMT-S, DriveLuxe 50LMTHD, Nuvi 3597LMTHD, Oregon 550T, Nuvi 855, Nuvi 755T, Lowrance Endura Sierra, Bosch Nyon

No problems with lag typing

No problems with lag typing on my 765T with latest firmware installed.

don't notice any lag either

don't notice any lag either on the 4.00 firmware. Wish they would fix the issue where it routes you towards the off ramp then has you get back on. Very annoying.

Red text for speed indicator

Aardvark wrote:

I have noticed an existing bug that was in 3.90 and is still in 4.00. I only figured out the way to reproduce it recently and I have to report it when I finally get a chance to sit down and write something coherent to Garmin support. In a nutshell, if you have a favorite that you want to navigate to and a picture is associated with it, clicking the "Go" button will not "Go" if the picture is not yet loaded in the display. About a month after I got the 765T, I would notice that I was starting off on my drive after having pressed "Go" and it was not routing. It was still in free drive mode. I would go back two or three times trying to get it to start routing and it wouldn't. Then the other day, under 4.00, I had the same thing happen again but I happened to recall that the picture was not yet displayed. I tried routing again before the picture appeared and, sure enough, it wouldn't go. Then I went back to the favorites, let the picture completely load, pressed "Go" and it worked. I had always thought it was something with 3.90 and the key press issues but that is not the case. It is a minor annoyance but hopefully I can get it into the system for the 4.10 update whenever that comes out.

One thing I hope they fix is the speed indicator when traveling faster than the speed limit - with the latest software, the numbers turn red when this happens. This is VERY difficult to read, perhaps a better solution would be to turn the background red and the numbers white (similar to a stop sign in colors), maybe that would be easier to read, especially at night.

--
Garmin c340, Nuvi 350, Nuvi 765T, Nuvi 2360LMT

that explains it....

Aardvark wrote:

I have noticed an existing bug that was in 3.90 and is still in 4.00. I only figured out the way to reproduce it recently and I have to report it when I finally get a chance to sit down and write something coherent to Garmin support. In a nutshell, if you have a favorite that you want to navigate to and a picture is associated with it, clicking the "Go" button will not "Go" if the picture is not yet loaded in the display. ........

Thanks.... I've had that happen numerous times and just kept trying until it worked... I've got a large mp3 file to load and I'm sure that adds to the delay.

everything comes to he who waits....

--
John Nuvi 750 765T Winnipeg, MB
1 2 3 4
<<Page 5