Extra POI editor error

 

Does anyone know why evertime I use extra POI editor I get a "Script" error code. It has the same "line 14" and character "314" error message everytime.

It seems to be caused when it inserts the map into the lower left box.

I have to hit "Yes" 3 times before the error message is eliminated.

Thx

--
Nuvi 350 long gone, Nuvi 855LMT, Nuvi 2797LMT, SmartDrive 50 LMT-HD, 3790LMT now my daughters. Using Windows 10. DashCam A108C with GPS.

.

I would suspect the Google API's on that one. TurboCCC said they had been changed about 2? years ago.

Ergo, the program doesn't work as well as it used to for map displays.

--
nüvi 3790T | nüvi 775T | Those who make peaceful revolution impossible, will make violent revolution inevitable ~ JFK

What version

I just checked my EPE v5.91 and all is well.

--
All the worlds indeed a stage and we are merely players. Rush

Try this

No difference

Thanks jgermann
I followed the http://www.poi-factory.com/node/38053 destructions to the letter, got the message that the TurboCC keys have been deleted from the registry.

Tried a file and get the same error message still, just at the point where it installs the map.

After I hit the error message 3 times the program works fine for about 10 or so conversions but get the error message every time and then it locks up and I get the "Program is not responding" windows message.

As an aside, if my memory serves me right, was there not some sort of file that you had to get from TurboCC for certain errors? This would be a few years ago. It is not shown on the Turbo CC website now.

I have copied the exact error message:
=============================================
An error has occured in the script in this page
Line 14
Char 346
Error Library not registered
code 0 (ZERO my add)
URL http://maps/gstatic.com/mapfiles/api-3/17/9/main js (My add there is a space between main and js)

Do you want to continue running scripts on this page?
Yes No
========================================
Typing the URL into my browser I get this:
404 That's an error.
The requested URL/mapfiles/api-3/17/9/main%20js
was not found on this server. That's all we know.

--
Nuvi 350 long gone, Nuvi 855LMT, Nuvi 2797LMT, SmartDrive 50 LMT-HD, 3790LMT now my daughters. Using Windows 10. DashCam A108C with GPS.

Using EPE

I had simular errors in the past.. Could not put my finger on it but after a day or 2 it went away.. I still think it is a Google server not set up correct when you are tring to look at the map in EPE. If you connect to a diffent server on Google, it seems to go way.

Not sure how true this is but that is what I have fouind using the program.

--
Bobkz - Garmin Nuvi 3597LMTHD/2455LMT/C530/C580- "Pain Is Fear Leaving The Body - Semper Fidelis"

Google Maps API Issue?

Melaqueman wrote:

I have copied the exact error message:
=============================================
An error has occured in the script in this page
Line 14
Char 346
Error Library not registered
code 0 (ZERO my add)
URL http://maps/gstatic.com/mapfiles/api-3/17/9/main js (My add there is a space between main and js)

The only version of EPE that works properly with the current Google Maps is v5.91. Is this the version you're running? What is the input file that causes the error?

The text in your post shows the experimental Maps API (3.17) is being used, and this might be the cause of the "Library not registered" Javascript problem...

When I run EPE, it invokes the release version (3.16) of the Maps API with http://maps.gstatic.com/mapfiles/api-3/16/15/main.js

--
DriveAssist 50 (stolen), Nüvi 2595LMT

EPE

WAASup wrote:

The only version of EPE that works properly with the current Google Maps is v5.91. Is this the version you're running? What is the input file that causes the error?
The text in your post shows the experimental Maps API (3.17) is being used, and this might be the cause of the "Library not registered" Javascript problem...
When I run EPE, it invokes the release version (3.16) of the Maps API with http://maps.gstatic.com/mapfiles/api-3/16/15/main.js

I downloaded EPE 5.91 and installed it. Regardless of whether I use a CSV file or a GPX file I get that error. As for API 3.17 to be honest I have no idea what it represents, certainly nothing I installed or make use of.

Are you suggesting I need to update the Java program?
Edit: I downloaded and installed Java Version 7 Update 65

Is maps API something I need to install?
Edit: Did a search but now download for this. How ???

--
Nuvi 350 long gone, Nuvi 855LMT, Nuvi 2797LMT, SmartDrive 50 LMT-HD, 3790LMT now my daughters. Using Windows 10. DashCam A108C with GPS.

.

Did you install EPE using the full installer? If not, please do so using this link: Extra_POI_Editor_Installer_v591_setup.exe

EPE doesn't use Java; it uses Javascript and the Maps API to display the POI on a map in the bottom right corner. There is nothing "extra" that you need to install.

Was EPE ever working correctly before? Do you eventually see the POI on a map after you reply "Yes" 3 times to the error message?

Does the source file come from the POI Factory? (If so, what is the file?) Does the source file load error-free with POI Loader?

--
DriveAssist 50 (stolen), Nüvi 2595LMT

EPE install

Yes WAASup, I used the full install Extra_POI_Editor_Installer_v591_setup.exe

It has always been doing this as far as I can remember, finally thought I'd find a reason maybe.

After clicking "Yes" 3 times it will work for about 10 times and then EPE freezes.

All my POI files come from POI factory and are in either CSV or GPX format. All files do give the same error. In fact the WiFi.csv file won't even load in EPE, EPE just sits there doing diddly squat and freezes up. I have to do the 3 finger salute to get out of it. There is no problem I encounter installing the POI's on either of my 2 Garmins using POI Loader. They show exactly where they are supposed to be. At least the ones I can verify.

I had used EPE a few years ago but why I have been using EPE a lot lately is that I like to see what the POI's look like on a map. I can not do that with CSV files. Yes EPE shows a small map, but I want to see the all POI's on a large scale map.I convert CSV files to GPX and for that I use MapSource and I can see where the locations are.

Incidentally that is how I ended up taking over an orphaned since 2007 POI file when I saw one waypoint was erroneously placed well out in the Pacific ocean instead of on the mainland and many other uncorrected errors.

--
Nuvi 350 long gone, Nuvi 855LMT, Nuvi 2797LMT, SmartDrive 50 LMT-HD, 3790LMT now my daughters. Using Windows 10. DashCam A108C with GPS.

All POIs does not work

Melaqueman wrote:

... Yes EPE shows a small map, but I want to see the all POI's on a large scale map.I convert CSV files to GPX and for that I use MapSource and I can see where the locations are.
...

That feature does not work for anyone. It is a problem that was created by Google changing an API. Turbocc might at some time fix the problem by finding the new API but do not expect it.

Sorry, we should have asked what keystrokes caused the error.

What?

[quote=jSorry, we should have asked what keystrokes caused the error.

I can not say it is a keystroke causing it. EPE goes through the motions and when it reaches the point where it displays the map in the lower left box, that is when the erreor pos up.

Well I'll have to live with it I guess. It's not that I do conversions froma nd to CVS and GPX all day every day.

Thanks for trying to solve this to you all.

--
Nuvi 350 long gone, Nuvi 855LMT, Nuvi 2797LMT, SmartDrive 50 LMT-HD, 3790LMT now my daughters. Using Windows 10. DashCam A108C with GPS.

Try another file

The wifi.csv file (2,278KB) will not load on my computer in EPE either (it does have 67713 entries according to NotePad ++). Indeed, Excel gives me a message it can not load the file completely and shows me 65536 entries.

Still, I think you have said the ANY file you load using EPE will cause an error! Assuming this to be the case, please do an experiment for us.

Load some small file - say,
http://www.poi-factory.com/node/19280

Now, play around with this file until the error occurs. Describe the keystroke(s) that caused the error.

John

It's a mystery...

I don't know why yu are getting these errors. You might be able to bypass them by turning the map display off (Options --> uncheck Enable Internet)

Melaqueman wrote:

All my POI files come from POI factory and are in either CSV or GPX format. All files do give the same error. In fact the WiFi.csv file won't even load in EPE, EPE just sits there doing diddly squat and freezes up.

The WiFi.csv file freezes on me too (EPE is looping). If I open it in Excel and re-save it, EPE opens the saved copy without any trouble.

Melaqueman also wrote:

I had used EPE a few years ago but why I have been using EPE a lot lately is that I like to see what the POI's look like on a map. I can not do that with CSV files. Yes EPE shows a small map, but I want to see the all POI's on a large scale map.I convert CSV files to GPX and for that I use MapSource and I can see where the locations are.

To see all the POIs on a map you could also open the CSV file with EPE, then select Tools --> Open in MapSource

--
DriveAssist 50 (stolen), Nüvi 2595LMT

Using Excel

jgermann wrote:

The wifi.csv file (2,278KB) will not load on my computer in EPE either (it does have 67713 entries according to NotePad ++). Indeed, Excel gives me a message it can not load the file completely and shows me 65536 entries.

Still, I think you have said the ANY file you load using EPE will cause an error! Assuming this to be the case, please do an experiment for us.

Load some small file - say,
http://www.poi-factory.com/node/19280

Now, play around with this file until the error occurs. Describe the keystroke(s) that caused the error.

John

Opening the wifi.csv file (2,278 KB) will not load on my computer in EPE either, only in Notepad or CSVed (http://csved.sjfrancke.nl/), but opening it in Excel and save it as CSV (Comma delimited) will now open in EPE. It could be the number of quotation marks on the original file. That's what I notice.

@ Melaqueman

I do not have the problem when using EPE on a Windows 64 bit computer with Internet Explorer 11

Do you have any add-on tool bars in your Internet Explorer?

I recall seeing someone posting (on another site)that they were getting a message quite similar to yours (but not related to EPE) and said that after trying all kinds of fixes, finally got rid of the message by removing one of the add-on tool bars.

If you have any, it may be worthwhile to either uninstall them or at least disable them temporarily.

Downloaded

jgermann wrote:

please do an experiment for us.
Load some small file - say,
http://www.poi-factory.com/node/19280

Did that and also did what WAASup suggested.

I can do anything in EPE and get no error. I can save as GPX, OK. But the little map does not show as well as going to the HELP file. In both cases it gives me the message that I need to enable INTERNET.

So judging by that it seems that that is the culprit.

--
Nuvi 350 long gone, Nuvi 855LMT, Nuvi 2797LMT, SmartDrive 50 LMT-HD, 3790LMT now my daughters. Using Windows 10. DashCam A108C with GPS.

No

Evert wrote:

I do not have the problem when using EPE on a Windows 64 bit computer with Internet Explorer 11

Do you have any add-on tool bars in your Internet Explorer?

I am running Windows 7 Ultimate 64bit.
I have IE 8 installed as everybody else using a Windows machine has, but I never use it. My preference is Mozilla Firefox v.30.0.
Also if and when installing a new program I very carefully check to make sure nothing I do not want gets installed. They always try to sneak something in on you.

--
Nuvi 350 long gone, Nuvi 855LMT, Nuvi 2797LMT, SmartDrive 50 LMT-HD, 3790LMT now my daughters. Using Windows 10. DashCam A108C with GPS.

John slaps forehead

WAASup wrote:

...
To see all the POIs on a map you could also open the CSV file with EPE, then select Tools --> Open in MapSource

Wow, I did not know I could do that

Thanks

Same Here

WAASup also wrote:

The WiFi.csv file freezes on me too (EPE is looping). If I open it in Excel and re-save it, EPE opens the saved copy without any trouble.

IE8

Melaqueman wrote:

...I am running Windows 7 Ultimate 64bit.
I have IE 8 installed as everybody else using a Windows machine has, but I never use it. ..

Not quite everyone. My W7 computer and the 40 W7 computers that I maintain as District Technology Coordinator for AARP Taxaide have IE11. We have to use IE because we use Taxwise Online and that will not work with Firefox, and we have to keep IE and Windows fully updated to meet IRS security requirements. I use IE on my computer because I have never had any problems with it.

I think that IE resources are used when EPE calls up the map, so you may be using it even if you don't think you are.

Therefore I think it would be worthwhile to update your IE and look in it to make sure there are no toolbar add-ons involved.

EPE freezing

As per WAASup's suggestion to stop EPE from accessing the internet I can now open the HUGE WiFi.csv file without any problems and save it as a GPX file.

Thank you WAASup

I downloaded a whole lot of POI's and converted them to GPX and not once did EPE freeze up.
Of course I do not get to see the little location map anymore now.

--
Nuvi 350 long gone, Nuvi 855LMT, Nuvi 2797LMT, SmartDrive 50 LMT-HD, 3790LMT now my daughters. Using Windows 10. DashCam A108C with GPS.

You're welcome Melaqueman

If you do want to see the map, internet can be toggled on/off using Ctrl-W.

Evert is correct - internally, EPE uses Internet Explorer to display the Google maps. IE8 is getting quite old - Internet Explorer 11 launched on October 17, 2013

--
DriveAssist 50 (stolen), Nüvi 2595LMT

Even if you never use it,

Even if you never use it, updating to IE11 is a good idea. Unless mistaken, some Windows functions still rely on IE.

--
"Anyone who is capable of getting themselves made President should on no account be allowed to do the job." --Douglas Adams

updating IE

Strephon_Alkhalikoi wrote:

Even if you never use it, updating to IE11 is a good idea. Unless mistaken, some Windows functions still rely on IE.

As per WAASup, Evert and your suggestion I will update IE and see if that is the culprit.

--
Nuvi 350 long gone, Nuvi 855LMT, Nuvi 2797LMT, SmartDrive 50 LMT-HD, 3790LMT now my daughters. Using Windows 10. DashCam A108C with GPS.

Thank you, thank you

A follow up!

Thanks for all the advice. It took me a while to update to IE 11 since I also had to install SP1 for Windows 7.

Now EPE works flawlessly. Also thanks to jgermann who sent me instructions from POI factory how to set a distance alert using EPE. So much easier than doing each individual file in POI Loader.

*-) '-)

--
Nuvi 350 long gone, Nuvi 855LMT, Nuvi 2797LMT, SmartDrive 50 LMT-HD, 3790LMT now my daughters. Using Windows 10. DashCam A108C with GPS.

Great

Melaqueman wrote:

A follow up!

Thanks for all the advice. It took me a while to update to IE 11 since I also had to install SP1 for Windows 7.

Now EPE works flawlessly. Also thanks to jgermann who sent me instructions from POI factory how to set a distance alert using EPE. So much easier than doing each individual file in POI Loader.

*-) '-)

I am glad it worked for you. smile

Thanks for reporting back

Glad that IE 11 fixed the issue for you Melaqueman!

So now we know strange things can happen with EPE and IE8 smile

--
DriveAssist 50 (stolen), Nüvi 2595LMT