StreetPilot C550 Fuse of the Car Chargers goes off

 

I have had this issue at least 2 times now in 2 different cars. When I have the Streetpilot C550 Car Charger /Traffic Signal Adapter plugged into my car Charger outlet, the charger stopped charging after few days. I thought it was a problem with the GPS Charger .But it seems the Fuse of the Car Charger Outlet went off. This happened in 2 different cars for me and it happened only when i used the Streetpilot C550 getting charged. Did anyone had this issue?Can you provide a solution?

Make Sure

I assume that since you changed the fuse that the tip is tight. A fuse blows when it gets too hot, either by a short or too much current draw. Check and make sure that there are not any kinks or cuts in the charging cable and feel the temperature when it is charging. It should not feel hot to the touch.

It could have been a faulty second fuse, not likely, but I have seen that at times after replacing one in a power supply. Just make sure it was the same rating as the one you replaced.

Daniel

--
Garmin StreetPilot c580 & Nuvi 760 - Member 32160 - Traveling in Kansas

will check

dkeane wrote:

I assume that since you changed the fuse that the tip is tight. A fuse blows when it gets too hot, either by a short or too much current draw. Check and make sure that there are not any kinks or cuts in the charging cable and feel the temperature when it is charging. It should not feel hot to the touch.

It could have been a faulty second fuse, not likely, but I have seen that at times after replacing one in a power supply. Just make sure it was the same rating as the one you replaced.

Daniel

Thanks Daniel. I'll check it out. The charging cable was good but let me take another look at it.

Jig.

I had problems

I had problems with it coming apart. Make sure the tip is on tight and has good 'spring action'.

http://www.poi-factory.com/node/10946

--
sewisdom - Drive carefully. The life you save... may be someone who owes you money!