Anyone else having trouble connecting to garmin servers

 

Is anyone else having trouble connecting with the garmin servers. Just got the Garmin DriveDelux 51-lmt-s just a few days ago. Connected fine wireless and wired. Downloaded update to the operating system with wireless and then came inside and updated maps using wired method. Have connected numerous times since then both wireless and wired. Yesterday, no connection at all. It says "Cannot connect with the update server. Try installing updates later." My other gps's can't connect either.

I also can't connect to the

I also can't connect to the Garmin servers today using Garmin Express.

Yes ...

... There is a known issue with the Drive 51 series, others should be okay.

--
Where there's a will ... there's a way ... DriveSmart50LMT-D, Nuvi 2508LMT-D, 1490LMT, 1310, Montana 650T, Etrex 20

Thanks

Thanks Sussamb! I knew that it was something wrong, but none of my gps's would connect and still won't. The guy at garmin stated that everything is up and running. Not! Oh well, guess that we'll have to wait and see.

If ...

... you're having issues with everything you may want to run through the tips in this FAQ https://support.garmin.com/faqSearch/en-US/faq/content/uZQHy...

--
Where there's a will ... there's a way ... DriveSmart50LMT-D, Nuvi 2508LMT-D, 1490LMT, 1310, Montana 650T, Etrex 20

YES... Yesterday I tried

YES... Yesterday I tried updating GE and it slowely did about 1/5 of it then showed Bright RED text: FAILED

Today I tried same thing... got about 1/2 way, faster than yesterday, then showed Bright RED Text: FAILED

--
A 2689LMT in both our cars that we love... and a Nuvi 660 with Lifetime Maps that we have had literally forever.... And a 2011 Ford Escape with Nav System that is totally ignored!

Trouble

Sussamb,
That's was the first thing that I did. Also, contacted Garmin this morning and the tech that I talked to stated that since it was not requiring an update, I would get an error message. Seems strange to me but I noticed that I can't get any new voices, cars, or anything else that I got with my old one. We'll just have to wait until a new update comes out, and then we will find out. But JanJ, everything is fine with the servers at garmin........LOL!!

not the last bug ...

Based on Garmin's history, I suspect this is not the last bug we will see with the 2017 Drive models. The next map update cycle will be very interesting to see what issues users run into when they start to use the new wi-fi feature.

--
Alan - Android Auto, DriveLuxe 51LMT-S, DriveLuxe 50LMTHD, Nuvi 3597LMTHD, Oregon 550T, Nuvi 855, Nuvi 755T, Lowrance Endura Sierra, Bosch Nyon

Well .....

I haven't used my Nuvi 2555LMT in quite a while. I fired it up today to update some POI files and my Windows 10 doesn't recognize my Nuvi, as well as the MTP Device driver in Device Manager. Tried to do a driver update but windows said there was a problem i.e. "A service installation section in this INF is invalid".

I did a manual install to change the driver with a driver already on my PC and used the MTP USB Device driver instead. Seems to work fine now ....

I find this strange ..... the previous driver was not changed, why should it stop working?

The automatic search for an updated driver always tries to install the MTP Device driver and always with the same error.

Obviously something changed somewhere ..... maybe the latest windows update?????????

Anyone encounter anything similar?

--
If the only tool you have is a hammer, every problem quickly resembles a nail. (Maslow's Hammer)

Anyone else having trouble connecting to garmin servers

The Garmin servers are iffy.

Sometimes a quick connection, and other times it takes several attempts to get on.

Hit or Miss

It has been hit or miss for me. Sometimes Garmin Express will connect on the first try, other times it might after clicking the reload button a time or two. There have also been a few times where it would not connect. I just try later if that's the case.

Win10

Win10 is particularly bad at dealing with devices in mtp mode. If you use Win10 best to switch your device to mass storage mode.

--
Where there's a will ... there's a way ... DriveSmart50LMT-D, Nuvi 2508LMT-D, 1490LMT, 1310, Montana 650T, Etrex 20

Seems that way ...

sussamb wrote:

Win10 is particularly bad at dealing with devices in mtp mode. If you use Win10 best to switch your device to mass storage mode.

The ole standby of performing a clean/total uninstall (revo)of GE and a new download/install seems to have reset the conflicts and everything works again with the default drivers.

I guess I shouldn't be surprised .....

--
If the only tool you have is a hammer, every problem quickly resembles a nail. (Maslow's Hammer)

no problem

Updated map today. Garmin Express needed an update first. It was uneventful.

nuvi 3597
Windows 7 x64

dobs108 smile

Same here

Just fixed it by updated the Garmin Express then updated the map.