POI Loader Will Not Work

 

I have a new 360 and use Windows Vista. I have downloaded Garmin's POI Loader and a file of E85 Gas Stations. The file's in a separate folder named Custom POI and is a .csx file. When I run the Loader, it says 'there are are no data files in that directory'. The file is definitely in that directory though. Am I doing something really dumb, or is there some obvious answer? Thanks in advance for the help!

Needs to be a csv file.

Needs to be a csv file. Maybe that will do it

Thanks - I misstyped it - it

Thanks - I misstyped it - it is a csv file. sorry and thanks again.

When you hooked the gps unit

When you hooked the gps unit to the computer with the usb cable and started poi loader did it find your unit?

--
Charlie. Nuvi 265 WT and Nuvi 2597 LMT. Android Here WeGo - Offline Maps & GPS.

Yes

It found the unit with no problem. I had a brainstorm and disabled PC Doctor, then reloaded the POI Loader program - -still no luck. Thanks for the thoughts!

Can you take one of the

Can you take one of the locations of the file and put it on your forum here and let us see what it looks like.Also check this thread out to make sure in right format. http://www.poi-factory.com/garmin-csv-file-format

--
Charlie. Nuvi 265 WT and Nuvi 2597 LMT. Android Here WeGo - Offline Maps & GPS.

.

Are you sure it's a CSV?

I vaguely recall a discussion (maybe last week) about an E85 file and someone said that it was a GPI file.

If that's the case, just copy it to the POI folder on your GPS unit.

The Total File . . .

Dodgy data


-93.246591,44.172179,"Bob Anhorn's Service, Inc.",216 S Main St
-93.576674,45.015865,, <-MISSING PARAMETERS
-94.811901,45.670676,Melrose Motor,423 S 2nd Ave E

-96.430514,45.298363,Cenex,849 Hwy 75
-93.402129,45.120695,, <-MISSING PARAMETERS
-95.579836,46.430793,Oasis,245 N HWY 78

--
------------------------ Phil Hornby, Stockport, England ----------------------               http://GeePeeEx.com - Garmin POI Creation made easy           »      

.

Ok, yikes! Didn't really mean for you to post the entire contents of the file in the post.

So, let's back up.

Where did the file come from?

Is it a CSV? (I'm assuming you opened it with Notepad in order to paste the info in the thread.) Check the file extension.

Is the data valid?

Are you sure that it is in the folder named Custom POI that you created on your computer?

Did you select that folder (the correct one) when you ran POI Loader?

Edited to add: Phil was posting at the same time and appears to have found the errors.

Beat you to it!

Just for once smile

--
------------------------ Phil Hornby, Stockport, England ----------------------               http://GeePeeEx.com - Garmin POI Creation made easy           »      

Invalid file

You have an extra CR on one line causing Road to be on a line by itself. It was about line 950 but I didn't note the exact line number.

Works

I loaded the complete file into a nuvi 350 and it loaded completely ... 1138 lines. Even though the blank on field 3 isn't 'correct structure', it doesn't keep the csv file from loading. Running POI Verifier will put a space in all blank in fields 3 and 4. I didn't see any extra carriage return in line 950 when viewing it either Notepad or Excel.

RT

--
"Internet: As Yogi Berra would say, "Don't believe 90% of what you read, and verify the other half."

?

retiredtechnician wrote:

I loaded the complete file into a nuvi 350 and it loaded completely ... 1138 lines.

I got 1141 records, when it fully loaded into GeePeeEx Editor smile

--
------------------------ Phil Hornby, Stockport, England ----------------------               http://GeePeeEx.com - Garmin POI Creation made easy           »      

You're correct

Hornbyp wrote:

I got 1141 records, when it fully loaded into GeePeeEx Editor smile

You're correct. I failed to copy the last 3 lines. Loaded and ran all 1141 lines ok.

RT

--
"Internet: As Yogi Berra would say, "Don't believe 90% of what you read, and verify the other half."

Thank You!

Thank you all for your efforts. It seems that the file is Okay then . . .I will look more fully into making sure I have a valid copy of POI Loader . . Thanks again!!