nuvi 2xx7 and 2xx8 software version 5.30

 

nuvi 2xx7 and 2xx8 software version 5.30

as of January 20, 2016
Use Garmin Express to install this file.

(45.42 MB)

View system requirements
Change History
Changes made from version 5.20 to 5.30:

Fixed an issue that prevented some traffic cables from being recognized.

Seems like a large download 45.42 MB.

--
Charlie. Nuvi 265 WT and Nuvi 2597 LMT. Android Here WeGo - Offline Maps & GPS.

Thanks

For the notice.

Large file

As you say, seems a big file for such a seemingly small update.

--
Nuvi2797LMT (2) Nuvi260,Ford Sync3 Navigation. Captain Cook was a Yorkshire man too.

Looks like

...i have some updating to do.

--
Until morale improves the beatings will continue

Firmware

bpaine wrote:

As you say, seems a big file for such a seemingly small update.

I suspect Garmin firmware (device software) updates are like map updates ... complete installs rather than incremental updates. Generally Garmin software updates are cumulative ... you can install the latest version even if your current version is behind by multiple updates. I know there have been a few rare exceptions to this where a new version had a dependency on a specific previous version being installed first, but AFAIK, most Garmin device software updates are cumulative.

--
Alan - Android Auto, DriveLuxe 51LMT-S, DriveLuxe 50LMTHD, Nuvi 3597LMTHD, Oregon 550T, Nuvi 855, Nuvi 755T, Lowrance Endura Sierra, Bosch Nyon

Cured my traffic issue

I was negatively impacted by the upgrade to 5.20 and installing 5.30 solved the traffic receiver issue for me.

--
Nuvi 760 Nuvi 2598 LMT Nuvi 3597 LMT Garmin Streetpilot Onboard for iPhone

Strange

Started Garmin Express up and checked for this update, it shows I have version 5.20 and tells me I am up to date on my 2797.

--
Nuvi2797LMT (2) Nuvi260,Ford Sync3 Navigation. Captain Cook was a Yorkshire man too.

Update

bpaine wrote:

Started Garmin Express up and checked for this update, it shows I have version 5.20 and tells me I am up to date on my 2797.

Should be 5.30. Did you use Webupdater or Garmin Express? Webupdater done it for me.

--
Charlie. Nuvi 265 WT and Nuvi 2597 LMT. Android Here WeGo - Offline Maps & GPS.

Update

I used the latest version of Garmin Express, I'll give Webupdater a try.

--
Nuvi2797LMT (2) Nuvi260,Ford Sync3 Navigation. Captain Cook was a Yorkshire man too.

No luck,

bpaine wrote:

I used the latest version of Garmin Express, I'll give Webupdater a try.

Just tried Webupdater, no luck, says I have the latest software.

--
Nuvi2797LMT (2) Nuvi260,Ford Sync3 Navigation. Captain Cook was a Yorkshire man too.

5.30

I have the 2597 and after your posted. Double checked in my settings about device and it shows 5.30. Makes you wonder if they pulled the update for some reason or the 2797 not part of the update .Need input from another 2797 owner.

--
Charlie. Nuvi 265 WT and Nuvi 2597 LMT. Android Here WeGo - Offline Maps & GPS.

Hmm

bpaine wrote:

I used the latest version of Garmin Express, I'll give Webupdater a try.

Express at first didn't do it for me either. Kept telling no space left. Having issues with one of my units i decided to uninstall express and d/l the current version. After that Express did the update n/p. I reloaded one of my older maps onto my unit and actually tried webupdater prior and it worked...sort of. It showed 5.30 but express showed it not being updated.

--
3580LMT - 2598LMT - DriveSmart 65 --- We do not live in Igloo's and do not all ride to work on snow mobiles.

2797

bpaine wrote:

Started Garmin Express up and checked for this update, it shows I have version 5.20 and tells me I am up to date on my 2797.

Same for me as well, I have 5.20 and GE says I am up to date. Tried WuD but no joy.

--
(formerly known as condump) RV 770 LMT-S, Nuvi2797LMT, Nuvi765T

Uninstall

Gastx wrote:
bpaine wrote:

Started Garmin Express up and checked for this update, it shows I have version 5.20 and tells me I am up to date on my 2797.

Same for me as well, I have 5.20 and GE says I am up to date. Tried WuD but no joy.

d/l a fresh copy, uninstall the old one, reinstall new copy.
Worked for me.

--
3580LMT - 2598LMT - DriveSmart 65 --- We do not live in Igloo's and do not all ride to work on snow mobiles.

Hmmmmm

I will give it a try tomorrow. I hate to have to do that as I have 6 GPS's registered in GE and will have to add them back again after the reinstall. Butttttttttt.......

--
(formerly known as condump) RV 770 LMT-S, Nuvi2797LMT, Nuvi765T

Not A Biggy

Gastx wrote:

I will give it a try tomorrow. I hate to have to do that as I have 6 GPS's registered in GE and will have to add them back again after the reinstall. Butttttttttt.......

Or not. Up to you, they are already registered you don't have to add the e-mail. Betcha that's just for advertising. I don't register

--
3580LMT - 2598LMT - DriveSmart 65 --- We do not live in Igloo's and do not all ride to work on snow mobiles.

No Joy

Did a full uninstall of GE and a fresh installation of GE (downloaded fresh copy). Still says no update needed but my 2797 shows it is at 5.20 (in GE and on the GPS itself in the "about" section.

I don't use the traffic reliever anyway so I am not concerned over this update at this point.

Thanks

--
(formerly known as condump) RV 770 LMT-S, Nuvi2797LMT, Nuvi765T

Edit the device's XML file

Gastx wrote:

Did a full uninstall of GE and a fresh installation of GE (downloaded fresh copy). Still says no update needed but my 2797 shows it is at 5.20 (in GE and on the GPS itself in the "about" section.

I don't use the traffic reliever anyway so I am not concerned over this update at this point.

Thanks

There's an XML file (Garmin or Device - I don't remember and I'm not going to grab my 3597 to look) in the root directory. In that file will be an entry stating Version and will show either 5.2 or 5.3. Change that entry to read 5.1 and rerun express. Express will read that file, determine you are down-rev and then update the unit.

--
Illiterate? Write for free help.

But ...

... Having changed it don't allow your nuvi to reboot as it will then overwrite the amended file.

--
Where there's a will ... there's a way ... DriveSmart50LMT-D, Nuvi 2508LMT-D, 1490LMT, 1310, Montana 650T, Etrex 20

in the \Garmin folder.

GarminDevice.xml is in the \Garmin folder, not the root.

--
Alan - Android Auto, DriveLuxe 51LMT-S, DriveLuxe 50LMTHD, Nuvi 3597LMTHD, Oregon 550T, Nuvi 855, Nuvi 755T, Lowrance Endura Sierra, Bosch Nyon

Why

Box Car wrote:
Gastx wrote:

Did a full uninstall of GE and a fresh installation of GE (downloaded fresh copy). Still says no update needed but my 2797 shows it is at 5.20 (in GE and on the GPS itself in the "about" section.

I don't use the traffic reliever anyway so I am not concerned over this update at this point.

Thanks

There's an XML file (Garmin or Device - I don't remember and I'm not going to grab my 3597 to look) in the root directory. In that file will be an entry stating Version and will show either 5.2 or 5.3. Change that entry to read 5.1 and rerun express. Express will read that file, determine you are down-rev and then update the unit.

Why are we telling Gastx to do this again?
He still has Traffic? I would like some one in here to prove that the update actually brings back traffic to some one who lost it. It doesn't for me. Then maybe re-writing the xml file has a point. Btw You might need to copy the file to the h/d first, then edit it. Delete the original file on the Garmin and copy the new one.

--
3580LMT - 2598LMT - DriveSmart 65 --- We do not live in Igloo's and do not all ride to work on snow mobiles.

A number have ...

Both on this forum and others, see cagpsfan's post above for one, and 5.30 was issued by Garmin specifically to deal with it. Why are you doubting it?

If it's not working for you maybe you have another issue, but that doesn't negate the worth of the 5.30 update for others.

--
Where there's a will ... there's a way ... DriveSmart50LMT-D, Nuvi 2508LMT-D, 1490LMT, 1310, Montana 650T, Etrex 20

I'm confused

Speed2 wrote:

Why are we telling Gastx to do this again?
He still has Traffic? I would like some one in here to prove that the update actually brings back traffic to some one who lost it. It doesn't for me. Then maybe re-writing the xml file has a point. Btw You might need to copy the file to the h/d first, then edit it. Delete the original file on the Garmin and copy the new one.

@Speed2 ... I am confused by your posts in this thread as well as http://www.poi-factory.com/node/45586. Which model of nuvi are you updating with the 5.30 software being discussed here? Your profile does not show you having a 2xx7 or 2xx8 nuvi and in the other thread I linked to you are discussing a traffic problem with your 3590. So do you have a 2xx7 or 2xx8 or are you having a similar problem on the 3590?

--
Alan - Android Auto, DriveLuxe 51LMT-S, DriveLuxe 50LMTHD, Nuvi 3597LMTHD, Oregon 550T, Nuvi 855, Nuvi 755T, Lowrance Endura Sierra, Bosch Nyon

No Joy

I edited the device.xml file from 520 to 510, saved and re-ran GE, still reports the unit as 5.20. Rebooted and the file had been overwritten back to 5.20.

I suspect GE is polling the device memory and not the actual xml file.

I may have to go into the system directory and do some snooping but since my traffic works ( I dont use it but did confirm it working).

Thanks for the responses but my 2797 works fine as is. I will just wait until 5.40 comes out and see what happens then.

Thanks again

--
(formerly known as condump) RV 770 LMT-S, Nuvi2797LMT, Nuvi765T

yes

alandb wrote:
Speed2 wrote:

Why are we telling Gastx to do this again?
He still has Traffic? I would like some one in here to prove that the update actually brings back traffic to some one who lost it. It doesn't for me. Then maybe re-writing the xml file has a point. Btw You might need to copy the file to the h/d first, then edit it. Delete the original file on the Garmin and copy the new one.

@Speed2 ... I am confused by your posts in this thread as well as http://www.poi-factory.com/node/45586. Which model of nuvi are you updating with the 5.30 software being discussed here? Your profile does not show you having a 2xx7 or 2xx8 nuvi and in the other thread I linked to you are discussing a traffic problem with your 3590. So do you have a 2xx7 or 2xx8 or are you having a similar problem on the 3590?

And it updated to 5.30, so its not just for the 2xx7-8

node/45606

--
3580LMT - 2598LMT - DriveSmart 65 --- We do not live in Igloo's and do not all ride to work on snow mobiles.

Thanks

Thanks for the update notice.

Device software vs GTM receiver software.

Speed2 wrote:
alandb wrote:
Speed2 wrote:

Why are we telling Gastx to do this again?
He still has Traffic? I would like some one in here to prove that the update actually brings back traffic to some one who lost it. It doesn't for me. Then maybe re-writing the xml file has a point. Btw You might need to copy the file to the h/d first, then edit it. Delete the original file on the Garmin and copy the new one.

@Speed2 ... I am confused by your posts in this thread as well as http://www.poi-factory.com/node/45586. Which model of nuvi are you updating with the 5.30 software being discussed here? Your profile does not show you having a 2xx7 or 2xx8 nuvi and in the other thread I linked to you are discussing a traffic problem with your 3590. So do you have a 2xx7 or 2xx8 or are you having a similar problem on the 3590?

And it updated to 5.30, so its not just for the 2xx7-8

node/45606

I still wonder if we are talking about two different things here. I think the 5.20/5.30 software being discussed in this thread is the device software for the 2xx7/2xx8 nuvis. Isn't the 35x0 nuvi software up to version 8.20 or something like that? Or is the 5.30 software being discussed here for the GTM traffic receivers? That is a totally different thing than nuvi device software. Would that explain why 5.30 software fixes the problem for the 2xx7/2xx8 nuvi's, but not for Speed2 on the 3590?

--
Alan - Android Auto, DriveLuxe 51LMT-S, DriveLuxe 50LMTHD, Nuvi 3597LMTHD, Oregon 550T, Nuvi 855, Nuvi 755T, Lowrance Endura Sierra, Bosch Nyon

Yes

I see your point. redface
Software 8.20 on the 3590
The update i took was a traffic update under utilities/other files
I remember seeing 5.30. Its not showing anything in device information on Traffic and since my cable won't work it doesn't show me my subscriptions either. traffic.xml file shows v4.10, not sure what that means since it under a part number. Either way you are right...2 different things, other than my traffic doesn't work either.

TrafficProvider.xsd"
partNumber="006-D1545-00"
version="4.10"

--
3580LMT - 2598LMT - DriveSmart 65 --- We do not live in Igloo's and do not all ride to work on snow mobiles.