Garmin Express and "Extras" not loading

 

I had noted a problem about "Extras" not loading in GE in another thread and someone else mentioned that they also had the problem.

Well the "Garmin Forum" came through with a solution. Here it is:

1.Open Garmin Express
2.Click Device
3.Click Delete Device from Express
4.Uncheck the box next to Delete the saved backups
5.Click Yes to remove the device
6.Close Garmin Express and restart the computer
7.Open Garmin Express and follow the on-screen prompts to add the device back to Express

It worked for me and continued to work after I installed the new GE - v3.0.12.0.

Thanks to the Garmin tech that posted it.

--
Metricman Nuvi 660, GTM-20 Traffic Receiver Nuvi 3597 GTM-60 Traffic Receiver Williamsburg, VA

Thanks

Thanks for posting, good to know.

Thank you

Thank you

Disappointed

metricman wrote:

I had noted a problem about "Extras" not loading in GE in another thread and someone else mentioned that they also had the problem.

Well the "Garmin Forum" came through with a solution. Here it is:

1.Open Garmin Express
2.Click Device
3.Click Delete Device from Express
4.Uncheck the box next to Delete the saved backups
5.Click Yes to remove the device
6.Close Garmin Express and restart the computer
7.Open Garmin Express and follow the on-screen prompts to add the device back to Express

It worked for me and continued to work after I installed the new GE - v3.0.12.0.

Thanks to the Garmin tech that posted it.

Followed the above but I don't see any improvement.... Even after the latest update 3.1.6.0 ..........

--
If the only tool you have is a hammer, every problem quickly resembles a nail. (Maslow's Hammer)

Also try this

While updating my nuvi 760, Garmin Express hung on the start of the map update. I went to the Garmin site to check Garmin Communicator, a browser plug-in:

http://software.garmin.com/en-US/gcp.html

Communicator was already installed but it was being blocked by the browser (Chrome) and I had to click on "always trust content from Garmin." I had done this several times in the past but this always happens again. Anyway, Communicator was now working.

After I went through the delete device procedure that metricman listed, Garmin Express worked properly.

dobs108 smile

Try it again

pb46 wrote:

Followed the above but I don't see any improvement.... Even after the latest update 3.1.6.0 ..........

I had upgraded to 3.0.12.0. Missed the upgrade to 3.1.6.0. Seems it only fixes:
"•Fix a crash impacting users who upgraded to 3.1.5.0 from pre-3.0.9.0 versions of Express"

I can only recommend trying it again and be sure to close every program before re-booting.

--
Metricman Nuvi 660, GTM-20 Traffic Receiver Nuvi 3597 GTM-60 Traffic Receiver Williamsburg, VA