new & interesting places for your GPS

Zumo 550 Slow with Actual Position

 

Since I've started using the latest map update, CTNANT 2013.1, for the Zummo 550, I'm noticing that as I'm traveling, the map is not keeping up with my actual current position as quickly as it did before this map udpate. Is anyone else experiencing this problem with their Nuvi or Zumo? What is the solution, besides going back to the previous map 2012.4?

Yes, I have, didn't connect it to the map version though

Humm, I may have to revert back and see if that helps.

I wrote the following in another forum ....

I am having trouble with my Zumo 550. software is up to date, and I have map version 2013.10 (East), I normally put the rest of North America on the 4GB SD card but while trouble shooting I erased it and left it blank. I can reload at will as I have lifetime updates for this unit.

This unit has three “views” you can use. Here they are and the problems I’ve had.

3D; The Map freezes, well sort of, it seems like its a 1/4 mile behind all of the time, so it's not a total freeze, the description line at the top still works while moving along in real time announcing the upcoming street, as do my direction and speed. Even the blue triangle I have set as "me" seems to rotate in the direction I am going but stays behind with the map otherwise.

North Up; The vehicle icon moves along as it should, however map drawing isn't working right. Picture the map as a grid of squares, the square you're in the icon moves along fine but surrounding squares are blank until you move into one. (no matter what ZOOM I used)

Track Up This worked the best until I hit highway speeds then it too lagged behind. Also, when I make a turn it takes a block or two to flip to track up, and sometimes experiences the black portions of screen like track up does.

I prefer the 3D mode as I'm used to it, the other two are too hard to follow. Oh, and I was just using a "rolling" map not a programmed destination.

Things I’ve already tried. Reinstalled the maps split between the unit and SD card, reinstalled the maps only on the SD card, reinstalled what would fit only on the unit, nothing on SD card. I have replaced the battery.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

Familiar experiences

soberbyker wrote:

Humm, I may have to revert back and see if that helps.

I wrote the following in another forum ....

I am having trouble with my Zumo 550. software is up to date, and I have map version 2013.10 (East), I normally put the rest of North America on the 4GB SD card but while trouble shooting I erased it and left it blank. I can reload at will as I have lifetime updates for this unit.

This unit has three “views” you can use. Here they are and the problems I’ve had.

3D; The Map freezes, well sort of, it seems like its a 1/4 mile behind all of the time, so it's not a total freeze, the description line at the top still works while moving along in real time announcing the upcoming street, as do my direction and speed. Even the blue triangle I have set as "me" seems to rotate in the direction I am going but stays behind with the map otherwise.

North Up; The vehicle icon moves along as it should, however map drawing isn't working right. Picture the map as a grid of squares, the square you're in the icon moves along fine but surrounding squares are blank until you move into one. (no matter what ZOOM I used)

Track Up This worked the best until I hit highway speeds then it too lagged behind. Also, when I make a turn it takes a block or two to flip to track up, and sometimes experiences the black portions of screen like track up does.

I prefer the 3D mode as I'm used to it, the other two are too hard to follow. Oh, and I was just using a "rolling" map not a programmed destination.

Things I’ve already tried. Reinstalled the maps split between the unit and SD card, reinstalled the maps only on the SD card, reinstalled what would fit only on the unit, nothing on SD card. I have replaced the battery.

I take it that no one was able to offer any solutions in the other forum you posted that in?

Sure sounds like the same experiences I've had with the "view" options I've tried. I have all of Canada and US on a 16 GB SD Card with my MP3s, but no maps on the unit. I too prefer the 3-D mode. After I did the map update, my MP3s would not display anymore. I had to reorganize the Artist folders with tracks limited to 20 for each folder as I learned through another forum.

Not really

Got the reinstall, try a hard reset, update software yada yada yada, nothing worked.

Contacted Garmin, not sure how much help they will be for a discontinued unit, they so far suggested a Master Reset, after telling me to do all the stuff I had already tried.

Now I need to find out how to do a master reset, if it's different than a hard reset.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

Defrag

Whenever my Zumo 665, Nuvi 1450 or either of my Nuvi 765Ts seem slow I usually run a defrag on the drive. I started this when I had one of them really acting up and when I checked the drive I found it was very fragmented. It ran much better afterwards.

I usually clean up the drive and delete all unnecessary and old files before defragging. Anyway, it can't hurt.

--
Zumo 665, (2) Nuvi 765Ts & 1450LMT | 2005 Harley Road King, Black Cherry Pearl / Black Pearl

.

Never, ever, ever defrag solid state memory. Ever.

Master Reset for Zumo 550

soberbyker wrote:

Got the reinstall, try a hard reset, update software yada yada yada, nothing worked.

Contacted Garmin, not sure how much help they will be for a discontinued unit, they so far suggested a Master Reset, after telling me to do all the stuff I had already tried.

Now I need to find out how to do a master reset, if it's different than a hard reset.

Garmin calls it a Master Reset. Refer to this for directions:

https://support.garmin.com/support/searchSupport/case.faces?caseId={981611c0-aa7d-11dd-f60b-000000000000}

Make sure you backup your Favorites to your PC first.

I thought so

I already did a hard reset, I thought that's what they meant by master reset.

Thanks

rwrimes wrote:
soberbyker wrote:

Got the reinstall, try a hard reset, update software yada yada yada, nothing worked.

Contacted Garmin, not sure how much help they will be for a discontinued unit, they so far suggested a Master Reset, after telling me to do all the stuff I had already tried.

Now I need to find out how to do a master reset, if it's different than a hard reset.

Garmin calls it a Master Reset. Refer to this for directions:

https://support.garmin.com/support/searchSupport/case.faces?caseId={981611c0-aa7d-11dd-f60b-000000000000}

Make sure you backup your Favorites to your PC first.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

Curious

Motorcycle Mama wrote:

Never, ever, ever defrag solid state memory. Ever.

@MM,

I don't defrag regularly but it has fixed problems for me as well as many others on this site when nothing else had, including a constantly resetting GPS that a Master Reset did nothing for. So why do you say never, ever, ever defrag when it obviously does work for some problems?

--
Zumo 665, (2) Nuvi 765Ts & 1450LMT | 2005 Harley Road King, Black Cherry Pearl / Black Pearl

.

You cannot "defrag" a solid state memory device, but you can cause it to move the data around and possibly expose bad sectors in the process which may have been causing read errors previously. That is most likely why the device suddenly starts to work better afterward, as needed data is no longer on those bad sectors.

However, you're also decreasing the life of the solid state memory by writing to it constantly, as the number of write cycles in a Nuvi SSM would most definitely be much lower then current consumer SSD's.

So the best practice, don't ever defrag unless it's the last possible option to try and fix a unit having software (not hardware) problems.

Talked to Garmin ....

.... and they suggested all the stuff I had already tried. I also paid $30 for a GPS place to "tune it up" to no avail. Garmin said they will sell me another unit for $150, I'm guessing refurbished, but it's a lot cheaper than the $700 or more motorcycle GPS's are commanding these days.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

Yes Refurbished

soberbyker wrote:

.... and they suggested all the stuff I had already tried. I also paid $30 for a GPS place to "tune it up" to no avail. Garmin said they will sell me another unit for $150, I'm guessing refurbished, but it's a lot cheaper than the $700 or more motorcycle GPS's are commanding these days.

I returned my Zumo 550 that I had for several years, because Garmin suggested I return it for repair. So I did for $150.00, and I got a refurbished unit that was even older than the one I had bought new. I'm still using the refurbished unit today. Did the new 5.0 software update Saturday along with a Master Reset, and still no improvement with the tracking positioning.

If you do decide to return your unit to Garmin for a replacement, please let us know if the situation is corrected.

is the ...

refurbished unit the one you are having the map freeze/lag problem?

rwrimes wrote:
soberbyker wrote:

.... and they suggested all the stuff I had already tried. I also paid $30 for a GPS place to "tune it up" to no avail. Garmin said they will sell me another unit for $150, I'm guessing refurbished, but it's a lot cheaper than the $700 or more motorcycle GPS's are commanding these days.

I returned my Zumo 550 that I had for several years, because Garmin suggested I return it for repair. So I did for $150.00, and I got a refurbished unit that was even older than the one I had bought new. I'm still using the refurbished unit today. Did the new 5.0 software update Saturday along with a Master Reset, and still no improvement with the tracking positioning.

If you do decide to return your unit to Garmin for a replacement, please let us know if the situation is corrected.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

Yes

Yes, the refurbished unit I have now is having the map freeze/lag problem. It started after the CTNANT 2013.1 map update. At least that's when it became noticeable to me. I've switched from the 3D mode to the Track Up mode and it has improved some. have you tried that yet?

eleven posts above yours ....

You quoted my post where I mention all that I tried and found .... but yes I found that to be best but not perfect especially at higher speeds.

rwrimes wrote:

Yes, the refurbished unit I have now is having the map freeze/lag problem. It started after the CTNANT 2013.1 map update. At least that's when it became noticeable to me. I've switched from the 3D mode to the Track Up mode and it has improved some. have you tried that yet?

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

Return to Garmin?

Sorry, I had forgotten that you made note of that already. Are you going to return the unit to Garmin for a refurbished unit?

yes

rwrimes wrote:

Sorry, I had forgotten that you made note of that already. Are you going to return the unit to Garmin for a refurbished unit?

Have it boxed up ready to ship in the morning. They tell me about two weeks from when they get it they will ship the replacement, they also told me that the lifetime map updates I had bought will transfer to the new (to me) unit.

I will report back if it was worth it. The newer Zumo's are going for $700 or more and looking for a Zumo 550 found prices of over a grand.

I have the power kit set up on two motorcycles and since the newer models use different stuff to run I had to try this first.

(fingers crossed)

.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

not looking good

Got the refurbished unit yesterday.

They had a map from 2009 loaded onto the unit taking up all but 60mb of space, entire North America. I added my SD card to update to the 2013.10 map (I had/have lifetime updates for the unit) leaving the 2009 in tact.

During the transfer of the map via the Garmin website the unit went blank, bright blue then white. It was stuck that way. I took out the battery which reset it.

I then downloaded the entire N.A. via mapsource to the SD card. That went OK.

Went into settings and unchecked the 2009 map and left the 2013 checked. Drove to work using the 3D mode and all was great. I did have a little trouble with the powercord (in my car), but I was thinking it may be the cord itself. Once it lit up though all was good.

Return home after work, unit won't power up at all, with or without the cord. Got home tried it on the motorcycle power nothing, called Garmin they're taking it back and we'll try again.

Let ya know how that works out.

.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

Wow

Would not have expected that on a refurbished unit. I wonder what is so special about the 2009 map with the Zumo 550 for them to have installed it and not the latest version of maps?

You might consider next time doing the map transfer to your SD card with MapInstall instead of MapSource. Garmin is not supporting or updating MapSource anymore.

I hope the next unit they send works for you. I look forward to seeing your next update about this.

the size is my guess

rwrimes wrote:

Would not have expected that on a refurbished unit. I wonder what is so special about the 2009 map with the Zumo 550 for them to have installed it and not the latest version of maps?

~snip~

I'm guessing the 2009 maps were the last to be able fit the entire North America on the 550. Looking at the properties there was only about 60mb left on the unit drive. When new, the 550 fit the entire N.A. on it, that was in 2007 when I first got it.

I purchased lifetime map updates with my original 550 and they transferred it to the refurb unit they sent and will do the same with the next, so it's not a problem for me.

.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

Update

soberbyker wrote:

Got the refurbished unit yesterday.

They had a map from 2009 loaded onto the unit taking up all but 60mb of space, entire North America. I added my SD card to update to the 2013.10 map (I had/have lifetime updates for the unit) leaving the 2009 in tact.

During the transfer of the map via the Garmin website the unit went blank, bright blue then white. It was stuck that way. I took out the battery which reset it.

I then downloaded the entire N.A. via mapsource to the SD card. That went OK.

Went into settings and unchecked the 2009 map and left the 2013 checked. Drove to work using the 3D mode and all was great. I did have a little trouble with the powercord (in my car), but I was thinking it may be the cord itself. Once it lit up though all was good.

Return home after work, unit won't power up at all, with or without the cord. Got home tried it on the motorcycle power nothing, called Garmin they're taking it back and we'll try again.

Let ya know how that works out.

.

soberbyker,
Did you get your refurbished Zumo 550 back from Garmin yet? If you did, how's it working for you?

no

rwrimes wrote:

soberbyker,
Did you get your refurbished Zumo 550 back from Garmin yet? If you did, how's it working for you?

The second refurbished unit is on back order.

.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

Reason for 2009 North America Map on Zumo 550

Quote:

I'm guessing the 2009 maps were the last to be able fit the entire North America on the 550. Looking at the properties there was only about 60mb left on the unit drive. When new, the 550 fit the entire N.A. on it, that was in 2007 when I first got it.

.

soberbyker,
I had some contact with Garmin yesterday and they told me that the refurbished units come with North America 2009 maps, because that is the map that was released on the unit. When the unit is refurbished, it is loaded with the original image that the device was sold with.

I guess ....

rwrimes wrote:
Quote:

I'm guessing the 2009 maps were the last to be able fit the entire North America on the 550. Looking at the properties there was only about 60mb left on the unit drive. When new, the 550 fit the entire N.A. on it, that was in 2007 when I first got it.

.

soberbyker,
I had some contact with Garmin yesterday and they told me that the refurbished units come with North America 2009 maps, because that is the map that was released on the unit. When the unit is refurbished, it is loaded with the original image that the device was sold with.

.... that's possible since it's 2012 and we are already on the second 2013 update for my 2460LMT. I bought the Zumo in 2008 (not 2007) with help from Uncle Sam's stimulus check.

I too talked with Garmin and they should have a replacement for me sometime next week, I'll let ya know how that goes.

.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

Got the second replacement

Got the second replacement today, updated the maps added a few POI's and will test it out tonight, let ya know how it went.

.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

alls good .... so far

soberbyker wrote:

Got the second replacement today, updated the maps added a few POI's and will test it out tonight, let ya know how it went.

.

The unit again came with the 2009 version of the map. I updated it to the 2013.2. Eastern US and Canada fit on the unit, the rest went on the SD card. That too went without a hitch.

Took the maiden voyage on my bike with the new refurbished unit, all went well. Took a ride consisting of both local and interstate roads, both with just the map on and with a programmed route. Went past a couple POI's and the alert displayed.

So, even though I went the whole summer without my motorcycle GPS it now seems as if i have it back.

For now, I'm happy and the case is closed, I'll report back if that changes.

.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

Just wanted to add ...

... on the programmed route I deviated from the route several times and the re-calculations were very quick.

The map moved right along with me, although not as smoothly as my much newer 2460.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

Garmin Zumo 550

Rwrimes,

Here I have just been considering a used Garmin Zumo 550, but I am guessing that you would not recommend that at this point then?

Not so

Jim1348 wrote:

Rwrimes,

Here I have just been considering a used Garmin Zumo 550, but I am guessing that you would not recommend that at this point then?

Jim1348,
No, I very much like my Zumo 550 and would always recommend it. I'm surprised Garmin has put it on the obsolete list. I believe it is a great unit and works pretty well, until some bugs get into it from Users, like myself, making modifications, or improper downloads, or just from long use of it. Soberbyker, seems to have had a good turn around with his Zumo 550 after sending it back to Garmin for refurbishment. I believe I'm probably going to do that now myself, since it tracks slower than it used to. I'm a Member of another site dedicated to Zumo users and constantly read about all the issues the others are having with the newer models of the Zumo. I really like the MP3 part of mine. The Zumo 660 and 665 are having issues with the MP3s not playing. The newest Zumo 350 does not come with the feature to play MP3s or any other music media.

Hope this information helps you decide.

Good to hear

soberbyker wrote:
soberbyker wrote:

Got the second replacement today, updated the maps added a few POI's and will test it out tonight, let ya know how it went.

.

The unit again came with the 2009 version of the map. I updated it to the 2013.2. Eastern US and Canada fit on the unit, the rest went on the SD card. That too went without a hitch.

Took the maiden voyage on my bike with the new refurbished unit, all went well. Took a ride consisting of both local and interstate roads, both with just the map on and with a programmed route. Went past a couple POI's and the alert displayed.

So, even though I went the whole summer without my motorcycle GPS it now seems as if i have it back.

For now, I'm happy and the case is closed, I'll report back if that changes.

.

Good to hear it turned out well for you!

Garmin Zumo 550

rwrimes wrote:

.....I very much like my Zumo 550 and would always recommend it.....

By any chance do you know of any place that might still have refurbished units available? I suspect that I will have to get one through Ebay or Craigslist, but if any dealer has new, old stock or refurbished units, I would like to know.

NEW???

Jim1348 wrote:
rwrimes wrote:

.....I very much like my Zumo 550 and would always recommend it.....

By any chance do you know of any place that might still have refurbished units available? I suspect that I will have to get one through Ebay or Craigslist, but if any dealer has new, old stock or refurbished units, I would like to know.

New is going to be very hard to find, and if you do, very expensive.

Because the mounting hardware is different for the ZUMO 550 than other ZUMO's, and I have the hardware on two bikes, I wanted another 550. The only one's I found (online)for sale were over $1000 (US), they weren't much less when they were in circulation.

The refurbished one I have now was IN EXCHANGE for my defective unit and that was directly from Garmin.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

eBay

soberbyker wrote:
Jim1348 wrote:
rwrimes wrote:

.....I very much like my Zumo 550 and would always recommend it.....

By any chance do you know of any place that might still have refurbished units available? I suspect that I will have to get one through Ebay or Craigslist, but if any dealer has new, old stock or refurbished units, I would like to know.

New is going to be very hard to find, and if you do, very expensive.

Because the mounting hardware is different for the ZUMO 550 than other ZUMO's, and I have the hardware on two bikes, I wanted another 550. The only one's I found (online)for sale were over $1000 (US), they weren't much less when they were in circulation.

The refurbished one I have now was IN EXCHANGE for my defective unit and that was directly from Garmin.

I don't know of any other source than eBay right now, and this is only for used or previously owned. There's 3 listed on eBay right now.

Amazon has one

rwrimes wrote:

I don't know of any other source than eBay right now, and this is only for used or previously owned. There's 3 listed on eBay right now.

There's a used one for sale on Amazon for $800.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

Amazing!!

soberbyker wrote:
rwrimes wrote:

I don't know of any other source than eBay right now, and this is only for used or previously owned. There's 3 listed on eBay right now.

There's a used one for sale on Amazon for $800.

That's amazing!! I bought mine bran new for $500 back in 2007 or 2008. Paid $150 for a refurbished model from Garmin after sending in my original for repair. Sounds like a great deal to send it in again for repair.

I agree

rwrimes wrote:
soberbyker wrote:
rwrimes wrote:

I don't know of any other source than eBay right now, and this is only for used or previously owned. There's 3 listed on eBay right now.

There's a used one for sale on Amazon for $800.

That's amazing!! I bought mine bran new for $500 back in 2007 or 2008. Paid $150 for a refurbished model from Garmin after sending in my original for repair. Sounds like a great deal to send it in again for repair.

FWIW, I took mine for a spin again last night on the bike. Rode with just the map on the see if it keeps up, yep it does, programmed a route and went off route a few times, recalculated just fine and got me there. Works as if new, although not as smooth as my newer car GPS.

Next test will be to put it on my wifes bike and do a similar test.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

No more testing

Forget the testing, just go fo a bike ride and get lost. Then let it bring you home!

Ride Safe,

--
Zumo 665, (2) Nuvi 765Ts & 1450LMT | 2005 Harley Road King, Black Cherry Pearl / Black Pearl

only have 30 days ....

bear007 wrote:

Forget the testing, just go fo a bike ride and get lost. Then let it bring you home!

Ride Safe,

to get a re-re-replacement if somethings wrong, but I get your meaning.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

3D Mode?

soberbyker wrote:

FWIW, I took mine for a spin again last night on the bike. Rode with just the map on the see if it keeps up, yep it does, programmed a route and went off route a few times, recalculated just fine and got me there. Works as if new, although not as smooth as my newer car GPS.

Next test will be to put it on my wifes bike and do a similar test.

Are you using it in 3D mode without any slow movement from the 550?

yes

rwrimes wrote:
soberbyker wrote:

FWIW, I took mine for a spin again last night on the bike. Rode with just the map on the see if it keeps up, yep it does, programmed a route and went off route a few times, recalculated just fine and got me there. Works as if new, although not as smooth as my newer car GPS.

Next test will be to put it on my wifes bike and do a similar test.

Are you using it in 3D mode without any slow movement from the 550?

Yep, thought I had mentioned that was my preferred method of use, it's not as smooth as my newer 2460, but it's just as good as it was new.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

.

soberbyker wrote:

Next test will be to put it on my wifes bike and do a similar test.

Kept meaning to get back to this, all went well on her bike as well. Different bike, different mount same results. Good to go.

--
. Nuvi 2460LMT, Zumo 550, Garmin preloaded into my Jeep, Beltronics Pro 500 radar detector with GPS built in, includes RLC info. Uconnect 430N (Garmin) built into my Jeep. .

sponsored links



Navigation



User login

Leave this blank! This field helps block spambots.

poi factory



Who's online

There are currently 21 users and 83 guests online.

Online users

  • john615
  • blake7mstr
  • zadmi
  • chuckwood
  • WAASup
  • DorkusNimrod
  • rdrivas
  • njsport95
  • mazel
  • LennyD51