Gtm60 semi-failure...help

 

I did the latest map update two nights ago...firmware, etc updated first...now my gtm60 will not receive traffic...it powers the device fine but I am getting the need proper traffic receiver message...the cable is not pinched or cut...there is, however, slight wiggle in the connector into the magnetic mount for the 3597. I had no problems before the latest updates. Anyone else have this problem, fixes?

TIA, Ted

--
"You can't get there from here"

Receiver problems

@TMK

I used to have a lot of traffic issues. I learned that Turning on or Plugging in the power cord first and then mounting my 3597 (or Nuvi 660) always worked best.

I now use Smartphone link , still do the same routine, and it just about always works. Whenever I very rarely have a problem, I power down the 3597 (by holding down the power button until message appears and clicking OK), leaving the cord plugged in and it comes up fine when powered back up.

I now have a truck with bluetooth (with internet data) and I get much better traffic coverage than with just the GTM-20. Although, I think the Smartphone app overrides the GTM-20.

--
Metricman Nuvi 660, GTM-20 Traffic Receiver Nuvi 3597 GTM-60 Traffic Receiver Williamsburg, VA

Thanks

I’ll try that!

--
"You can't get there from here"

Two ideas

Here are a couple thoughts

1) What happens if you plug the GTM60 directly into the 3597 skipping the mag mount? I've not tried this to know if it would offer traffic but it could bypass the mag mount which you say has a wiggle. Do you have any other USB cables that you could plug into the back of the mag mount to see if they also wiggle? That could help point out if it's the mount's socket that's loose or the cable's jack and whether the GTM60 or mag mount may be at fault.

2) I see two 3597 mounts offered now on eBay: roughly $40-60, and several GTM 60s offered at about the same price range.

Tried

metricman wrote:

@TMK

I used to have a lot of traffic issues. I learned that Turning on or Plugging in the power cord first and then mounting my 3597 (or Nuvi 660) always worked best.

I now use Smartphone link , still do the same routine, and it just about always works. Whenever I very rarely have a problem, I power down the 3597 (by holding down the power button until message appears and clicking OK), leaving the cord plugged in and it comes up fine when powered back up.

I now have a truck with bluetooth (with internet data) and I get much better traffic coverage than with just the GTM-20. Although, I think the Smartphone app overrides the GTM-20.

No joy...probably just going to keep using it without traffic until I decide on a new one in the future...the magnetic mount and cable are about $90...in a few months I can get a left over 65 or 61 for $150 smile

--
"You can't get there from here"

CraigW

CraigW wrote:

Here are a couple thoughts

1) What happens if you plug the GTM60 directly into the 3597 skipping the mag mount? I've not tried this to know if it would offer traffic but it could bypass the mag mount which you say has a wiggle. Do you have any other USB cables that you could plug into the back of the mag mount to see if they also wiggle? That could help point out if it's the mount's socket that's loose or the cable's jack and whether the GTM60 or mag mount may be at fault.

2) I see two 3597 mounts offered now on eBay: roughly $40-60, and several GTM 60s offered at about the same price range.

Tried the direct plug into the 3597 the other day...get a message it is not the right power cord (so maybe the mag mount is a booster?) versus the plugged message not a proper receiver cord.

Like I told MetricMan...I'll go without it as long as I can and then just get a new unit on sale. I really like the 3597 but for a couple bucks more than the parts I can get a much newer unit.

Thanks for the reply.

Ted

--
"You can't get there from here"

Traffic

--
Charlie. Nuvi 265 WT and Nuvi 2597 LMT. Android Here WeGo - Offline Maps & GPS.

I read that

charlesd45 wrote:

From Garmin support. https://support.garmin.com/en-US/?faq=uzBIs7xQKx0QM9Wufgldm7&productID=121762&searchQuery=traffic%20cable&tab=topics

The cable powers up just no traffic...95 in Philadelphia is definitely covered, etc.

--
"You can't get there from here"

DriveLuxe

TMK wrote:

I really like the 3597 but for a couple bucks more than the parts I can get a much newer unit.

Thanks for the reply.

Ted

A used DriveLuxe 51 could be a good move, or better yet, a factory refurb.

firmware update for GTM-60?

If Garmin Express had a firmware update for the 3597, there also could have been a firmware update for the GTM-60. After that, it would have to relearn by downloading digital files from the traffic subcarrier of an FM broadcast station, which could take 20 minutes.

First of all, the 3597 has to have a good fix, and the broadcast station must have a good signal before the download starts. The source for all this are popups on the screen of the 3597 that tells you what the GTM-60 is doing.

If you don't have a good FM traffic signal, the download will not start and the GTM-60 will appear dead. My prediction is when you drive to an area with a strong traffic signal the problem will be solved.

Be sure to get as much of the GTM-60 power cord as possible higher than the dashboard. The traffic antenna is inside the length of this cord.

In my opinion FM traffic is better than Smartphone Link, because I have had trouble repeatedly pairing bluetooth. That reminds me - disable Smartphone Link in the 3597 settings because it turns off FM traffic.

dobs108 smile

agree

That's exactly what happened when I first connected the traffic cable to my DRIVE 51. It kind of surprised me that after having it attached for a couple of days I was in heavy traffic and it started to update.

--
I never get lost, but I do explore new territory every now and then.

firmware update

Another thought - the firmware update could have failed. With my 3597, the automatic reboot after the firmware is downloaded never happens. I always have to do it manually.

Just run Garmin Express again and see if it updates the firmware. Follow the popups on the 3597 screen to see the status of the update. It only takes seconds for the download. Then restart manually.

Did you

Did you check to be sure that "Traffic" did not get turned off during the update? At one time updates would sometimes change your settings/preferences.

--
Metricman Nuvi 660, GTM-20 Traffic Receiver Nuvi 3597 GTM-60 Traffic Receiver Williamsburg, VA

I drive to Philadelphia

dobs108 wrote:

If Garmin Express had a firmware update for the 3597, there also could have been a firmware update for the GTM-60. After that, it would have to relearn by downloading digital files from the traffic subcarrier of an FM broadcast station, which could take 20 minutes.

First of all, the 3597 has to have a good fix, and the broadcast station must have a good signal before the download starts. The source for all this are popups on the screen of the 3597 that tells you what the GTM-60 is doing.

If you don't have a good FM traffic signal, the download will not start and the GTM-60 will appear dead. My prediction is when you drive to an area with a strong traffic signal the problem will be solved.

Be sure to get as much of the GTM-60 power cord as possible higher than the dashboard. The traffic antenna is inside the length of this cord.

In my opinion FM traffic is better than Smartphone Link, because I have had trouble repeatedly pairing bluetooth. That reminds me - disable Smartphone Link in the 3597 settings because it turns off FM traffic.

dobs108 smile

And Newark all the time...no updates, no notification, no traffic.

--
"You can't get there from here"

First thing

metricman wrote:

Did you check to be sure that "Traffic" did not get turned off during the update? At one time updates would sometimes change your settings/preferences.

I checked...it was on and I did a restore too boot.

--
"You can't get there from here"

Tried that too

dobs108 wrote:

Another thought - the firmware update could have failed. With my 3597, the automatic reboot after the firmware is downloaded never happens. I always have to do it manually.

Just run Garmin Express again and see if it updates the firmware. Follow the popups on the 3597 screen to see the status of the update. It only takes seconds for the download. Then restart manually.

no joy...not sure what happened but I don’t really believe in coincidence.

--
"You can't get there from here"