Never saw this before..... Upgrade issue

 

We have 2 2689LMT’s.
Both unit’s Maps were updated this evening.....
On Both, GE said the Update was Successful....
I tested both in their cars afterward. And.....
As I normally do, I check to see the map version info
Is updated.
First one OK. See that it loads maps OK.
Next one reports new map and Foursquare......
Wait!! First one said map only! Continue Test of Foursquare on #2
#2 is OK.
Go back into #1 car. Start 2689, check version Map—Yes, Foursquare No! Test Foursquare. No Data!!!

Oh SHUCKS!! (or the equivalent....)

Now What?
Back in house, back on same computer, GE Says No Updates are necessary! All OK!!
I stumble through software and find RELOAD MAP..
What the heck, what do I have to loose???
Do it!!
15 min later it again says it's done and all OK (Just like last time?)
Restart 2689. Check map version: NOW IT SHOWS MAP AND FOURSQUARE have been updated!!
Rush out to car.... Test..... Verify all OK!!! Maps, Foursquare, and all saved places!
YIPPEE!!!
It was my wife’s GPS!!!

So..... Just because GE says it completed successfully,
DON’T BELIVE IT!!! CHECK AND VERIFY!!!
And be happy they have Reload Maps!!

--
A 2689LMT in both our cars that we love... and a Nuvi 660 with Lifetime Maps that we have had literally forever.... And a 2011 Ford Escape with Nav System that is totally ignored!

this happened twice

This happened to me twice for the 3597. Garmin Express said the map update was successful, but it really wasn't. It was easy to fix by downloading the map again like you said.

dobs108 smile

Ditto

This also happened to me several times when updating my three 3597's. As was your experience, reloading the map solved the issue. I noticed during this process that when you download the map to device & computer, it shortens the download time for the second attempt.

Thanks dobs108 and

Thanks dobs108 and bdhsfz6.... Well, you gotta admidt---It Does get your attention when it happens!!!

I've had issues with my old 660, but nothing in maybe 5 years... making me complacent...

Thanks again!!

--
A 2689LMT in both our cars that we love... and a Nuvi 660 with Lifetime Maps that we have had literally forever.... And a 2011 Ford Escape with Nav System that is totally ignored!

Interesting ...

...I have the same unit (2689) but luckily all seems ok here. I took it out and tested it yesterday after downloading the new map. No problems detected. Hopefully the issue didn't affect too many other people. Thank you for sharing the info though.

To OP

To OP:
I don't understand why you had to go out to the car to check on the map and foursquare updates. What does going to the car show that can't be seen with the unit in hand?

Personal note: I would be happy if the foursquare and parkopedia were never updated and wasting download time. If only GE would allow you to uncheck those items it intends to update.

--
I never get lost, but I do explore new territory every now and then.

Well ...

It does allow you to select what to install, but unfortunately it doesn't split out the Foursquare data.

--
Where there's a will ... there's a way ... DriveSmart50LMT-D, Nuvi 2508LMT-D, 1490LMT, 1310, Montana 650T, Etrex 20

... or the parkopedia data

... or the parkopedia data

--
I never get lost, but I do explore new territory every now and then.

Wanted to make sure it

KenSny: I Wanted to make sure it 'sees' the traffic receiver too!

--
A 2689LMT in both our cars that we love... and a Nuvi 660 with Lifetime Maps that we have had literally forever.... And a 2011 Ford Escape with Nav System that is totally ignored!