Smileys & Input Format Are Showing (bug) ** fixed **

 

Update 2/19/2013

Click on smiley function is working now.

** Press Ctrl-F5 and/or refresh the page to clear out our browser cache if you're still experiencing this issue. **

Update 1/21/2013

Click on smiley function is still not working. Some users are still not seeing correct functioning of drop down areas.

Update 1/20/2013

Click on smiley function is still not working.

----

A bug has shown up in a few pages of the web site after I applied an update yesterday.

Normally, the areas for smileys and input format are hidden on the pages for editing posts and comments.

They should only show when the "drop down" icon is clicked to see these additional details, but now they are always visible.

Other than this display issue, the pages are functioning normally.

I'm working on finding a fix.

Regards,

Jonathan (aka JM)

Page 1>>

and in your spare time

Can you help Garmin fix some of their problems?

--
Illiterate? Write for free help.

OH

I thought it was something I had done.

--
1490LMT 1450LMT 295w

Yea please fix this as

Yea please fix this as evertime Boxcar posts I keep seeing a big rediculous smilie! smile

--
Nuvi 3790LMT, Nuvi 760 Lifetime map, Lifetime NavTraffic, Garmin E-Trex Legend Just because "Everyone" drives badly does not mean you have to.

HEY!

onestep wrote:

Yea please fix this as evertime Boxcar posts I keep seeing a big rediculous smilie! smile

I went to a lot of trouble to steal that from another forum!

--
Illiterate? Write for free help.

Really, Smileys?

I'm Relieved

I too thought it was me. I tried everything possible to fix it and couldn't. Although all Smileys appear. you cannot insert them in the post.

Had I been smart enough to check the Discussion forum I would have known it was not just me.

Good luck with the fix Jonathan.

--
Nuvi 2460LMT 2 Units

Today It Wouldn't

put a smiley on the end of my chit chat post. Or here either.

--
johnm405 660 & MSS&T

I read this post

on the 17th and checked my Post page. Smileys and Input Format expand and collapse fine so I thought the problem was already fixed. It is still working correctly for me.

question

--
Harley BOOM GTS, Zumo 665, (2) Nuvi 765Ts, 1450LMT, 1350LM & others | 2019 Harley Ultra Limited Shrine - Peace Officer Dark Blue

Still Not Working For Me

bear007 wrote:

on the 17th and checked my Post page. Smileys and Input Format expand and collapse fine so I thought the problem was already fixed. It is still working correctly for me.
question

You must know somebody in high places since I'm still unable to collapse the Input Format or add a Smiley as I write this. I wonder just how it can work for some and not for others. Maybe Jonathan is fixing in alphabetical order.

Note: Wanted to insert Smiley but coudn't, use your imagination.

--
Nuvi 2460LMT 2 Units

Happened before

Not the first time. Went away now its back. How to explain this other one. Dunno if its a bug, but sometimes when I read a post, come back later and new posts have bin added, I can click on "new" and usually it will put onto the new posts. Sometimes it won't and i'll need to scroll to find them. They also won't list as new. As an example, Garmin Lifetime Maps $86.00 has 20 new posts showing for me. If i click on 20 new
it will put me on the first page not on the 8th page. Its not always like that....hit and miss.

--
DriveSmart 65 - We do not live in Igloo's and do not all ride to work on snow mobiles.

Could it be Java?

http://www.poi-factory.com/node/38813

dobs108

I was unable to include a smiley in this post!

"New" link bug.

Speed2 wrote:

How to explain this other one. Dunno if its a bug, but sometimes when I read a post, come back later and new posts have bin added, I can click on "new" and usually it will put onto the new posts. Sometimes it won't and i'll need to scroll to find them. They also won't list as new. As an example, Garmin Lifetime Maps $86.00 has 20 new posts showing for me. If i click on 20 new
it will put me on the first page not on the 8th page. Its not always like that....hit and miss.

Speed2, if I understand your post correctly, I think that bug has been in this forum software for a long time. If there is only 1 page in the thread, the "New" link takes you to the correct post, but if there are multiple pages, it takes you to page 1. That is why most of the forum regulars I have talked to use the "unread posts" link rather than the "recent posts" link. "Unread posts" will consistantly take you to the first new post in the thread when there are multiple pages.

--
Alan - Android Auto, DriveLuxe 51LMT-S, DriveLuxe 50LMTHD, Nuvi 3597LMTHD, Oregon 550T, Nuvi 855, Nuvi 755T, Lowrance Endura Sierra, Bosch Nyon

Works manually for me

bear007 wrote:

on the 17th and checked my Post page. Smileys and Input Format expand and collapse fine so I thought the problem was already fixed. It is still working correctly for me.

question

I still have no problem inserting a smilie either although I just enter them manually; i.e., a

; - )

when all three characters are adjacent to each other run together to become a wink

If it matters, my Input Format is Filtered HTML which I assume is the default at The Factory since I don't think I ever changed it to one of the other options. It works for me so I've never tried a more complex way to enter messages. My method is a bit more of a hassle, I expect, when trying to create bold or italics since I manually have to type a < strong > and a < /strong > for bold (removing the two spaces between the brackets) and I imagine the other formats make this easier.

JavaScript Fixed

I installed another update today that should fix the smiley issue.

You might need to do a complete page refresh by pressing Ctrl-F5 to clear out any old components from your browser's cache.

Thanks for your understanding.

Jonathan (aka JM)

Fixed

JM wrote:

I installed another update today that should fix the smiley issue.

You might need to do a complete page refresh by pressing Ctrl-F5 to clear out any old components from your browser's cache.

Thanks for your understanding.

Jonathan (aka JM)

The F5 did the trick

--
1490LMT 1450LMT 295w

Thanks

JM wrote:

I installed another update today that should fix the smiley issue.

You might need to do a complete page refresh by pressing Ctrl-F5 to clear out any old components from your browser's cache.

Thanks for your understanding.

Jonathan (aka JM)

Thanks for the work.

It IS appreciated.

With best wishes,
- Tom -

--
XXL540, GO LIVE 1535, GO 620

>

Not working for me yet.

--
DriveSmart 65 - We do not live in Igloo's and do not all ride to work on snow mobiles.

.

Me either. Manual mode, Mr. Sulu! mrgreen

--
nüvi 3790T | nüvi 775T | Those who make peaceful revolution impossible, will make violent revolution inevitable ~ JFK

Smileys

Pressed the Ctrl-F5 and it's still not working on this end.

--
Nüvi 255WT with nüMaps Lifetime North America born on 602117815 / Nüvi 3597LMTHD born on 805972514 / I love Friday’s except when I’m on holidays ~ canuk

Browser differences, maybe?

canuk wrote:

Pressed the Ctrl-F5 and it's still not working on this end.

Different browsers may have different keyboard shortcuts for forcing a complete refresh. In Firefox, for example, [Ctrl-R] is a simple page reload, while [Ctrl-Shift-R] is a complete refresh (bypassing the cache).

Of course, completely emptying the browser cache is another option.

Partial Fix

JM wrote:

I installed another update today that should fix the smiley issue.

You might need to do a complete page refresh by pressing Ctrl-F5 to clear out any old components from your browser's cache.

Thanks for your understanding.

Jonathan (aka JM)

It was still not working last night. This morning I
thought it was fixed since the input format no longer was displayed and I have the option to change clicking on the blue "input format" text near the bottom.
My setting is Filtered HTML. I tried both IE8 and Firefox with browsers cleared, but I'm still unable to insert smileys.

--
Nuvi 2460LMT 2 Units

Still Not Workintg

won't work for me either. tried it twice.

--
johnm405 660 & MSS&T

.

muell9k wrote:

I tried both IE8 and Firefox with browsers cleared, but I'm still unable to insert smileys.

Try it again with Firefox. If the problem is still there, hit [Ctrl-Shift-R] to completely reload the page and all dependencies. See if that fixes it; it just did for me.

Still Not Working for Me

Windows 7 - Chrome, Firefox, IE8

Windows 8 - Chrome, IE10

--
Nüvi 2595LMT

Works for me on my home

Works for me on my home computer and work computer

--
All the worlds indeed a stage and we are merely players. Rush

Thanks But Suggestion Didn't Work

VersatileGuy wrote:
muell9k wrote:

I tried both IE8 and Firefox with browsers cleared, but I'm still unable to insert smileys.

Try it again with Firefox. If the problem is still there, hit [Ctrl-Shift-R] to completely reload the page and all dependencies. See if that fixes it; it just did for me.

Tried that, still not working with either Firefox Or IE8 on Win XP SP3.

--
Nuvi 2460LMT 2 Units

OK

It is still OK here. IE 8 XP.

--
1490LMT 1450LMT 295w

(No subject)

smile sad wink

--
Nuvi 3790LMT, Nuvi 760 Lifetime map, Lifetime NavTraffic, Garmin E-Trex Legend Just because "Everyone" drives badly does not mean you have to.

This is a T-E-S-T

--
"Advice to children crossing the street: Damn the lights. Watch the cars. The lights ain't never killed nobody." - Moms Mabley Garmin StreetPilot C330, Garmin NUVI 765T, Garmin DriveSmart 60LMT

>

Hmm.... why can I not edit my posts after I have placed them any more?

--
DriveSmart 65 - We do not live in Igloo's and do not all ride to work on snow mobiles.

I still see them

When I reply to this post, I still see the smileys and the input format blocks

oh oh

I just tried to edit my post and got this >

Access denied
You are not authorized to access this page.
home | top of page | unread posts

Can't edit it any more

--
DriveSmart 65 - We do not live in Igloo's and do not all ride to work on snow mobiles.

Post edit.

You can't edit a post after someone has replied to your specific post. This forum software has always worked that way (for me anyway). Also, if you have somehow been logged off, you might get that message. Not sure if that is what happened to you, but it might explain why your edit didn't work.

(Note: I just successfully edited this post).

--
Alan - Android Auto, DriveLuxe 51LMT-S, DriveLuxe 50LMTHD, Nuvi 3597LMTHD, Oregon 550T, Nuvi 855, Nuvi 755T, Lowrance Endura Sierra, Bosch Nyon

Fixed here

Smileys and Input Format back to normal.

Yep. Alanb is right. After someone clicks on the Reply or Quote button at the bottom of your post and enters a new post, you can no longer edit your post.

Edit: Checked after JM's post below and the Smiley menu will drop down, however I cannot add a Smiley to my post from the box. sad This smiley was added from the keyboard.

--
Garmin nüvi 3597LMTHD, 3760 LMT, & 255LMT, - "Those who wish for fairness without first protecting freedom will end up with neither freedom nor fairness." - Milton Friedman

Reviewing Open Issues

Thanks all for your follow-up.

I've been looking over the issue reports, and it appears we only have a partial fix.

Open issues:

Click on smiley function is still not working.

Some users are still not seeing correct functioning of drop down areas.

I am continuing to troubleshoot and work on a fix.

Thanks,

Jonathan

Thanks For Info

JM wrote:

Thanks all for your follow-up.

I've been looking over the issue reports, and it appears we only have a partial fix.

Open issues:

Click on smiley function is still not working.

Some users are still not seeing correct functioning of drop down areas.

I am continuing to troubleshoot and work on a fix.

Thanks,

Jonathan

Thanks for advising problems still remain. I'm sure you'll get it sorted out.

Edit: It appears I am able to edit, but not able to insert smileys. Baffled as to why some of us have issues where others do not.

--
Nuvi 2460LMT 2 Units

>

alandb wrote:

You can't edit a post after someone has replied to your specific post. This forum software has always worked that way (for me anyway). Also, if you have somehow been logged off, you might get that message. Not sure if that is what happened to you, but it might explain why your edit didn't work.

(Note: I just successfully edited this post).

They haven't replied, that's what i didn't get to say when i got that access denied. No biggy any ways. If its not the way it's supposed to be, some one else will observe the same problem

--
DriveSmart 65 - We do not live in Igloo's and do not all ride to work on snow mobiles.

Thanks VersatileGuy

For your suggestion, unfortunately it didn't help any but at least we're still able to add them in manually smile

--
Nüvi 255WT with nüMaps Lifetime North America born on 602117815 / Nüvi 3597LMTHD born on 805972514 / I love Friday’s except when I’m on holidays ~ canuk

Strange - F5 Worked For Me

Win7, IE9.

I'm also running the latest Java version 7 update 11.

It is also working correctly on my WinXP IE8 system with the latest Java version.

--
Tampa, FL - Garmin nüvi 660 (Software Ver 4.90), 2019.30 CN NA NT maps | Magellan Meridian Gold

Smileys don't work for me

Windows XP, SP3
Firefox 3.6.13 (old school!) smile
Internet Explorer 7.0.5730.13
JAVA version 6 Update 29 (build 1.6.0_29-b11)

The smiley drop down does function though, as before it was expanded and there was nothing you could do about it. (as was the input format, expanded and unable to shrink it) All variations of F5 failed as well.

--
Striving to make the NYC Metro area project the best.

Clicked on all Smileys

Smileys not working for me.

I did click on Edit and it is working for me.

--
Mary, Nuvi 2450, Garmin Viago, Honda Navigation, Nuvi 750 (gave to son)

Not able

I'm not able to insert a Smiley into a post any longer. Clicking on the word Smileys will open the drop down but clicking on any of the Smileys shown does not add the code to the post. I have cleared the browser cache using F5 as well as through the Network tab in Firefox Options.

I'm using FireFox 18.0.2 on a Windows 8 x64 laptop.

--
Nuvi 350, 760, 1695LM, 3790LMT, 2460LMT, 3597LMTHD, DriveLuxe 50LMTHD, DriveSmart 61, Garmin Backup Camera 40 and TomTom XXL540s.

Smiley bug

t923347 wrote:

I'm not able to insert a Smiley into a post any longer. Clicking on the word Smileys will open the drop down but clicking on any of the Smileys shown does not add the code to the post. ...

I'm still working on this. It broke when I installed a platform update last month that involved some jQuery / JavaScript chages.

In the past, I've previously worked mostly in PHP; so it's taking me quite a while to get my head around the exact cause of the problem and debug the issue. This week, I did have time to watch some jQuery tutorials and do some troubleshooting.

Slowly but surely... smile

.

JM wrote:
t923347 wrote:

I'm not able to insert a Smiley into a post any longer. Clicking on the word Smileys will open the drop down but clicking on any of the Smileys shown does not add the code to the post. ...

I'm still working on this. It broke when I installed a platform update last month that involved some jQuery / JavaScript chages.

In the past, I've previously worked mostly in PHP; so it's taking me quite a while to get my head around the exact cause of the problem and debug the issue. This week, I did have time to watch some jQuery tutorials and do some troubleshooting.

Slowly but surely... :)

If you're still using the older Smileys module you might want to try the newer derivative module Smiley. At the very least, their respective project pages list the former as "Minimally maintained" while the latter is "Actively maintained".

Click on Smiley

Click on smileys is working again. smile

** You will probably need to clear your browser cache (press Ctrl-F5 and/or reload the page) in order for your web browser to see the fix. **

When you're adding a comment or new post, you can select a smiley by clicking; and it will automatically insert the code into your text.

Jonathan (JM)

Just checking

grin Thanks neutral razz surprised

Did not have to refresh...

--
Mary, Nuvi 2450, Garmin Viago, Honda Navigation, Nuvi 750 (gave to son)

Works For Me Now

Thanks Jonathan for your hard work in solving the problem. I haven't been able to smile for a long time, but I now can.
grin grin grin grin

--
Nuvi 2460LMT 2 Units

Thanks

grin wink

--
Nuvi 2460LMT.

Thanks

No reload/refresh required on Chrome grin

--
Nüvi 2595LMT

Testing

arrow grin confused cool crying shock evil exclaim idea laugh out loud mad mrgreen neutral question razz redface rolleyes sad smile surprised twisted wink

It appears to be working well grin

--
Nüvi 255WT with nüMaps Lifetime North America born on 602117815 / Nüvi 3597LMTHD born on 805972514 / I love Friday’s except when I’m on holidays ~ canuk
Page 1>>